# CVE-2016-15022: mosbth cimage check_system.php cross site scripting


- **Severity:** Low 2.0 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 29 Jan 2023
- **Updated:** 27 Mar 2025
- **Also known as:** GHSA-6hv3-9fqx-8pg5

## What is CVE-2016-15022?

CVE-2016-15022 is a low-severity vulnerability in mosbth cimage, published on 29 Jan 2023. 

### Official description

A vulnerability was found in mosbth cimage up to 0.7.18. It has been declared as problematic. Affected by this vulnerability is an unknown functionality of the file check_system.php. The manipulation of the argument $_SERVER['SERVER_SOFTWARE'] leads to cross site scripting. The attack can be launched remotely. The complexity of an attack is rather high. The exploitation appears to be difficult. Upgrading to version 0.7.19 is able to address this issue. The patch is named 401478c8393989836beeddfeac5ce44570af162b. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-219715.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2016-15022?

2 open source packages ship an affected version, including mos/cimage. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mos/cimage` | Packagist | All versions | 0.7.19 |
| `mos/cimage` | Packagist | All versions | 0.7.19 |

Products: Cimage Cimage.

## How do I fix CVE-2016-15022?

Upgrade mos/cimage to 0.7.19 or later.

## Is CVE-2016-15022 being exploited?

There is no known exploitation of CVE-2016-15022 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-15022 and fix it if it is affected.

What it is: CVE-2016-15022 is a low-severity vulnerability in mosbth cimage, published on 29 Jan 2023. 
Exploitation: There is no known exploitation of CVE-2016-15022 in the wild and no public exploit code.

Affected packages and fixed versions:
- mos/cimage (Packagist): affected all versions; fixed in 0.7.19
- mos/cimage (Packagist): affected all versions; fixed in 0.7.19

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-15022/ (Markdown: https://insights.sbomify.com/CVE-2016-15022/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-15022
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-15022
- OSV: https://osv.dev/vulnerability/CVE-2016-15022

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-15022/
Summaries are generated and may contain mistakes; the official description above is the record.
