{"answers":{"affected":"2 open source packages ship an affected version, including generator-hottowel. It affects 1 product.","exploited":"There is no known exploitation of CVE-2016-15025 in the wild and no public exploit code.","fix":"Upgrade generator-hottowel to 0.5.0 or later.","what":"CVE-2016-15025 is a low-severity cross-site scripting vulnerability in generator-hottowel, published on 20 Feb 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2016-15025 and fix it if it is affected.\n\nWhat it is: CVE-2016-15025 is a low-severity cross-site scripting vulnerability in generator-hottowel, published on 20 Feb 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2016-15025 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- generator-hottowel (npm): affected all versions; fixed in 0.5.0\n- generator-hottowel (npm): affected all versions; fixed in 0.5.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-15025/ (Markdown: https://insights.sbomify.com/CVE-2016-15025/index.md)","id":"CVE-2016-15025","markdown":"https://insights.sbomify.com/CVE-2016-15025/index.md","name":"CVE-2016-15025","record":{"aliases":["GHSA-f8hv-rx9p-f9r4"],"analysis":{"component_type":"developer_tool","fix_type":"patch","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Yeoman generator","requires_auth":"low_privilege","summary":"Cross-site scripting vulnerability in the 404 error handler of generator-hottowel allows remote attackers to inject malicious scripts.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"generator-hottowel","vendor":"generator-hottowel_project"}],"cvss":{"score":3.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A vulnerability, which was classified as problematic, was found in generator-hottowel 0.0.11. Affected is an unknown function of the file app/templates/src/server/_app.js of the component 404 Error Handler. The manipulation leads to cross site scripting. It is possible to launch the attack remotely. The name of the patch is c17092fd4103143a9ddab93c8983ace8bf174396. It is recommended to apply a patch to fix this issue. The identifier of this vulnerability is VDB-221484.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"generator-hottowel 404 Error _app.js cross site scripting","id":"CVE-2016-15025","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2016"},"n_packages":2,"n_references":4,"next":{"headline":"3breadt dd-plist xml external entity reference","id":"CVE-2016-15026"},"packages":[{"ecosystem":"npm","fixed":["0.5.0"],"introduced":["0"],"last_affected":[],"package":"generator-hottowel","purl":null,"source":"GHSA-f8hv-rx9p-f9r4"},{"ecosystem":"npm","fixed":["0.5.0"],"introduced":["0"],"last_affected":[],"package":"generator-hottowel","purl":"pkg:npm/generator-hottowel","source":"GHSA-f8hv-rx9p-f9r4"}],"prev":{"headline":"doomsider shadow denial of service","id":"CVE-2016-15024"},"products":["generator-hottowel"],"published":"2023-02-20","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Cross-site scripting vulnerability in the 404 error handler of generator-hottowel allows remote attackers to inject malicious scripts.","url":"https://insights.sbomify.com/CVE-2016-15025/"}