# CVE-2016-15025: generator-hottowel 404 Error _app.js cross site scripting

> Cross-site scripting vulnerability in the 404 error handler of generator-hottowel allows remote attackers to inject malicious scripts.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 Feb 2023
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-f8hv-rx9p-f9r4

## What is CVE-2016-15025?

CVE-2016-15025 is a low-severity cross-site scripting vulnerability in generator-hottowel, published on 20 Feb 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A vulnerability, which was classified as problematic, was found in generator-hottowel 0.0.11. Affected is an unknown function of the file app/templates/src/server/_app.js of the component 404 Error Handler. The manipulation leads to cross site scripting. It is possible to launch the attack remotely. The name of the patch is c17092fd4103143a9ddab93c8983ace8bf174396. It is recommended to apply a patch to fix this issue. The identifier of this vulnerability is VDB-221484.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2016-15025?

2 open source packages ship an affected version, including generator-hottowel. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `generator-hottowel` | npm | All versions | 0.5.0 |
| `generator-hottowel` | npm | All versions | 0.5.0 |

Products: Generator-Hottowel Project Generator-Hottowel.

## How do I fix CVE-2016-15025?

Upgrade generator-hottowel to 0.5.0 or later.

## Is CVE-2016-15025 being exploited?

There is no known exploitation of CVE-2016-15025 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-15025 and fix it if it is affected.

What it is: CVE-2016-15025 is a low-severity cross-site scripting vulnerability in generator-hottowel, published on 20 Feb 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2016-15025 in the wild and no public exploit code.

Affected packages and fixed versions:
- generator-hottowel (npm): affected all versions; fixed in 0.5.0
- generator-hottowel (npm): affected all versions; fixed in 0.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-15025/ (Markdown: https://insights.sbomify.com/CVE-2016-15025/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-15025
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-15025
- OSV: https://osv.dev/vulnerability/CVE-2016-15025

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-15025/
Summaries are generated and may contain mistakes; the official description above is the record.
