CVE-2016-15026 3breadt dd-plist xml external entity reference

Medium 5.3 Published Updated

A local attacker can exploit an XML External Entity vulnerability in the dd-plist library to read sensitive files.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2016-15026?

CVE-2016-15026 is a medium-severity vulnerability in 3breadt dd-plist, published on 20 Feb 2023. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

A vulnerability was found in 3breadt dd-plist 1.17 and classified as problematic. Affected by this issue is some unknown functionality. The manipulation leads to xml external entity reference. An attack has to be approached locally. Upgrading to version 1.18 is able to address this issue. The patch is identified as 8c954e8d9f6f6863729e50105a8abf3f87fff74c. It is recommended to upgrade the affected component. VDB-221486 is the identifier assigned to this vulnerability.

Weakness: CWE-611

Which versions are affected by CVE-2016-15026?

2 open source packages ship an affected version, including com.googlecode.plist:dd-plist. It affects 1 product.

PackageAffectedFixed in
com.googlecode.plist:dd-plist MavenAll versions1.18
com.googlecode.plist:dd-plist MavenAll versions1.18

Products include Dd-Plist Project Dd-Plist.

How do I fix CVE-2016-15026?

Upgrade com.googlecode.plist:dd-plist to 1.18 or later.

Is CVE-2016-15026 being exploited?

There is no known exploitation of CVE-2016-15026 in the wild and no public exploit code.

Sources

Also known as GHSA-4jx2-hvqw-93j9.

Is CVE-2016-15026 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free