{"answers":{"affected":"2 open source packages ship an affected version, including com.googlecode.plist:dd-plist. It affects 1 product.","exploited":"There is no known exploitation of CVE-2016-15026 in the wild and no public exploit code.","fix":"Upgrade com.googlecode.plist:dd-plist to 1.18 or later.","what":"CVE-2016-15026 is a medium-severity vulnerability in 3breadt dd-plist, published on 20 Feb 2023. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-15026 and fix it if it is affected.\n\nWhat it is: CVE-2016-15026 is a medium-severity vulnerability in 3breadt dd-plist, published on 20 Feb 2023. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2016-15026 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- com.googlecode.plist:dd-plist (Maven): affected all versions; fixed in 1.18\n- com.googlecode.plist:dd-plist (Maven): affected all versions; fixed in 1.18\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-15026/ (Markdown: https://insights.sbomify.com/CVE-2016-15026/index.md)","id":"CVE-2016-15026","markdown":"https://insights.sbomify.com/CVE-2016-15026/index.md","name":"CVE-2016-15026","record":{"aliases":["GHSA-4jx2-hvqw-93j9"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Java plist library","requires_auth":"low_privilege","summary":"A local attacker can exploit an XML External Entity vulnerability in the dd-plist library to read sensitive files.","user_interaction":"not_required","vuln_class":"xxe"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"dd-plist","vendor":"dd-plist_project"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-611","name":"Improper Restriction of XML External Entity Reference"}],"description":"A vulnerability was found in 3breadt dd-plist 1.17 and classified as problematic. Affected by this issue is some unknown functionality. The manipulation leads to xml external entity reference. An attack has to be approached locally. Upgrading to version 1.18 is able to address this issue. The patch is identified as 8c954e8d9f6f6863729e50105a8abf3f87fff74c. It is recommended to upgrade the affected component. VDB-221486 is the identifier assigned to this vulnerability.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"3breadt dd-plist xml external entity reference","id":"CVE-2016-15026","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xxe","year":"2016"},"n_packages":2,"n_references":5,"next":{"headline":"meta4creations Post Duplicator Plugin notices.php mtphr_post_duplicator_notice cross site scripting","id":"CVE-2016-15027"},"packages":[{"ecosystem":"Maven","fixed":["1.18"],"introduced":["0"],"last_affected":[],"package":"com.googlecode.plist:dd-plist","purl":null,"source":"GHSA-4jx2-hvqw-93j9"},{"ecosystem":"Maven","fixed":["1.18"],"introduced":["0"],"last_affected":[],"package":"com.googlecode.plist:dd-plist","purl":"pkg:maven/com.googlecode.plist/dd-plist","source":"GHSA-4jx2-hvqw-93j9"}],"prev":{"headline":"generator-hottowel 404 Error _app.js cross site scripting","id":"CVE-2016-15025"},"products":["dd-plist"],"published":"2023-02-20","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["3breadt"]},"summary":"A local attacker can exploit an XML External Entity vulnerability in the dd-plist library to read sensitive files.","url":"https://insights.sbomify.com/CVE-2016-15026/"}