# CVE-2016-15026: 3breadt dd-plist xml external entity reference

> A local attacker can exploit an XML External Entity vulnerability in the dd-plist library to read sensitive files.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Feb 2023
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-4jx2-hvqw-93j9

## What is CVE-2016-15026?

CVE-2016-15026 is a medium-severity vulnerability in 3breadt dd-plist, published on 20 Feb 2023. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A vulnerability was found in 3breadt dd-plist 1.17 and classified as problematic. Affected by this issue is some unknown functionality. The manipulation leads to xml external entity reference. An attack has to be approached locally. Upgrading to version 1.18 is able to address this issue. The patch is identified as 8c954e8d9f6f6863729e50105a8abf3f87fff74c. It is recommended to upgrade the affected component. VDB-221486 is the identifier assigned to this vulnerability.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2016-15026?

2 open source packages ship an affected version, including com.googlecode.plist:dd-plist. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.googlecode.plist:dd-plist` | Maven | All versions | 1.18 |
| `com.googlecode.plist:dd-plist` | Maven | All versions | 1.18 |

Products: Dd-Plist Project Dd-Plist.

## How do I fix CVE-2016-15026?

Upgrade com.googlecode.plist:dd-plist to 1.18 or later.

## Is CVE-2016-15026 being exploited?

There is no known exploitation of CVE-2016-15026 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-15026 and fix it if it is affected.

What it is: CVE-2016-15026 is a medium-severity vulnerability in 3breadt dd-plist, published on 20 Feb 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-15026 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.googlecode.plist:dd-plist (Maven): affected all versions; fixed in 1.18
- com.googlecode.plist:dd-plist (Maven): affected all versions; fixed in 1.18

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-15026/ (Markdown: https://insights.sbomify.com/CVE-2016-15026/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-15026
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-15026
- OSV: https://osv.dev/vulnerability/CVE-2016-15026

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-15026/
Summaries are generated and may contain mistakes; the official description above is the record.
