# CVE-2016-15027: meta4creations Post Duplicator Plugin notices.php mtphr_post_duplicator_notice cross site scripting

> Remote attackers can inject malicious scripts via the post-duplicated argument in the Post Duplicator plugin, potentially compromising user sessions.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 20 Feb 2023
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-wj5x-h527-5hh4

## What is CVE-2016-15027?

CVE-2016-15027 is a low-severity cross-site scripting vulnerability in meta4creations Post Duplicator Plugin, published on 20 Feb 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A vulnerability was found in meta4creations Post Duplicator Plugin 2.18 on WordPress. It has been classified as problematic. Affected is the function mtphr_post_duplicator_notice of the file includes/notices.php. The manipulation of the argument post-duplicated leads to cross site scripting. It is possible to launch the attack remotely. Upgrading to version 2.19 is able to address this issue. The name of the patch is ca67c05e490c0cf93a1e9b2d93bfeff3dd96f594. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-221496.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2016-15027?

It affects 1 product.


Products: Metaphorcreations Post Duplicator.

## How do I fix CVE-2016-15027?

No fix has been published for CVE-2016-15027 yet. Limit exposure of the affected software until one is available.

## Is CVE-2016-15027 being exploited?

There is no known exploitation of CVE-2016-15027 in the wild and no public exploit code.

## Other vulnerabilities in meta4creations Post Duplicator Plugin

- [CVE-2021-33852](https://insights.sbomify.com/CVE-2021-33852/): Cross-site scripting in WordPress Post Duplicator Plugin (medium 5.4)
- [CVE-2025-24736](https://insights.sbomify.com/CVE-2025-24736/): WordPress Post Duplicator plugin <= 2.35 - Broken Access Control vulnerability (medium 4.3)
- [CVE-2024-12472](https://insights.sbomify.com/CVE-2024-12472/): Post Duplicator <= 2.36 - Authenticated (Contributor+) Protected Post Disclosure (medium 4.3)
- [CVE-2023-49835](https://insights.sbomify.com/CVE-2023-49835/): WordPress Post Duplicator plugin <= 2.31 - Broken Access Control vulnerability (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-15027 and fix it if it is affected.

What it is: CVE-2016-15027 is a low-severity cross-site scripting vulnerability in meta4creations Post Duplicator Plugin, published on 20 Feb 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2016-15027 in the wild and no public exploit code.

Affected product: meta4creations Post Duplicator Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-15027/ (Markdown: https://insights.sbomify.com/CVE-2016-15027/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-15027
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-15027
- OSV: https://osv.dev/vulnerability/CVE-2016-15027

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-15027/
Summaries are generated and may contain mistakes; the official description above is the record.
