{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2016-15029 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2016-15029 yet. Limit exposure of the affected software until one is available.","what":"CVE-2016-15029 is a low-severity vulnerability in Ydalb mapicoin, published on 21 Mar 2023."},"fix_prompt":"Check this codebase for CVE-2016-15029 and fix it if it is affected.\n\nWhat it is: CVE-2016-15029 is a low-severity vulnerability in Ydalb mapicoin, published on 21 Mar 2023. \nExploitation: There is no known exploitation of CVE-2016-15029 in the wild and no public exploit code.\n\nAffected product: Ydalb mapicoin. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-15029/ (Markdown: https://insights.sbomify.com/CVE-2016-15029/index.md)","id":"CVE-2016-15029","markdown":"https://insights.sbomify.com/CVE-2016-15029/index.md","name":"CVE-2016-15029","record":{"aliases":["GHSA-5p2w-2jhx-g423"],"analysis":null,"analysis_generated_by":null,"assigner":"VulDB","cpe":[{"product":"mapicoin","vendor":"mapicoin_project"}],"cvss":{"score":3.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A vulnerability has been found in Ydalb mapicoin up to 1.9.0 and classified as problematic. This vulnerability affects unknown code of the file webroot/stats.php. The manipulation of the argument link/search leads to cross site scripting. The attack can be initiated remotely. Upgrading to version 1.10.0 is able to address this issue. The patch is identified as 67e87f0f0c1ac238fcd050f4c3db298229bc9679. It is recommended to upgrade the affected component. VDB-223402 is the identifier assigned to this vulnerability.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Ydalb mapicoin stats.php cross site scripting","id":"CVE-2016-15029","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":null,"year":"2016"},"n_packages":0,"n_references":3,"next":{"headline":"Arno0x TwoFactorAuth login.php redirect","id":"CVE-2016-15030"},"packages":[],"prev":{"headline":"ICEPAY REST-API-NET Checksum Validation RestClient.cs RestClient integrity check","id":"CVE-2016-15028"},"products":["mapicoin"],"published":"2023-03-21","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["Ydalb"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2016-15029/"}