{"answers":{"affected":"3 open source packages ship an affected version, including github.com/deis/workflow-manager. It affects 1 product.","exploited":"There is no known exploitation of CVE-2016-15036 in the wild and no public exploit code.","fix":"Upgrade github.com/deis/workflow-manager to a fixed version for your release line: 2.3.3 or 2.3.3+incompatible.","what":"CVE-2016-15036 is a medium-severity vulnerability in Deis Workflow Manager, published on 23 Dec 2023. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-15036 and fix it if it is affected.\n\nWhat it is: CVE-2016-15036 is a medium-severity vulnerability in Deis Workflow Manager, published on 23 Dec 2023. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2016-15036 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/deis/workflow-manager (Go): affected all versions; fixed in 2.3.3\n- github.com/deis/workflow-manager (Go): affected all versions; fixed in 2.3.3\n- github.com/deis/workflow-manager (Go): affected all versions; fixed in 2.3.3+incompatible\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-15036/ (Markdown: https://insights.sbomify.com/CVE-2016-15036/index.md)","id":"CVE-2016-15036","markdown":"https://insights.sbomify.com/CVE-2016-15036/index.md","name":"CVE-2016-15036","record":{"aliases":["GHSA-jpfp-xq3p-4h3r","GO-2023-2422"],"analysis":{"component_type":"cloud_service","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Deis Workflow Manager","requires_auth":"low_privilege","summary":"A race condition in Deis Workflow Manager allows attackers to potentially escalate privileges, requiring an upgrade to the fixed version.","user_interaction":"not_required","vuln_class":"race_condition"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"workflow_manager","vendor":"deis"}],"cvss":{"score":4.6,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:A/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-362","name":"Concurrent Execution using Shared Resource with Improper Synchronization"}],"description":"** UNSUPPORTED WHEN ASSIGNED ** A vulnerability was found in Deis Workflow Manager up to 2.3.2. It has been classified as problematic. This affects an unknown part. The manipulation leads to race condition. The complexity of an attack is rather high. The exploitability is told to be difficult. Upgrading to version 2.3.3 is able to address this issue. The patch is named 31fe3bccbdde134a185752e53380330d16053f7f. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-248847. NOTE: This vulnerability only affects products that are no longer supported by the maintainer.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Deis Workflow Manager race condition","id":"CVE-2016-15036","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"race_condition","year":"2016"},"n_packages":3,"n_references":5,"next":{"headline":"go4rayyan Scumblr Task cross site scripting","id":"CVE-2016-15037"},"packages":[{"ecosystem":"Go","fixed":["2.3.3"],"introduced":["0"],"last_affected":[],"package":"github.com/deis/workflow-manager","purl":null,"source":"GHSA-jpfp-xq3p-4h3r"},{"ecosystem":"Go","fixed":["2.3.3"],"introduced":["0"],"last_affected":[],"package":"github.com/deis/workflow-manager","purl":"pkg:golang/github.com/deis/workflow-manager","source":"GHSA-jpfp-xq3p-4h3r"},{"ecosystem":"Go","fixed":["2.3.3+incompatible"],"introduced":["0"],"last_affected":[],"package":"github.com/deis/workflow-manager","purl":"pkg:golang/github.com/deis/workflow-manager","source":"GO-2023-2422"}],"prev":{"headline":"Doc2k RE-Chat re_chat.js cross site scripting","id":"CVE-2016-15035"},"products":["Workflow Manager"],"published":"2023-12-23","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["Deis"]},"summary":"A race condition in Deis Workflow Manager allows attackers to potentially escalate privileges, requiring an upgrade to the fixed version.","url":"https://insights.sbomify.com/CVE-2016-15036/"}