# CVE-2016-15037: go4rayyan Scumblr Task cross site scripting

> Remote attackers can inject malicious scripts into the Task Handler of Scumblr, potentially leading to code execution or account takeover.

- **Severity:** Low 2.4 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 21 Jan 2024
- **Updated:** 12 Sep 2024
- **Also known as:** GHSA-hh23-hp8m-rwv7

## What is CVE-2016-15037?

CVE-2016-15037 is a low-severity cross-site scripting vulnerability in go4rayyan Scumblr, published on 21 Jan 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

A vulnerability, which was classified as problematic, has been found in go4rayyan Scumblr up to 2.0.1a. Affected by this issue is some unknown functionality of the component Task Handler. The manipulation leads to cross site scripting. The attack may be launched remotely. Upgrading to version 2.0.2 is able to address this issue. The patch is identified as 5c9120f2362ddb7cbe48f2c4620715adddc4ee35. It is recommended to upgrade the affected component. VDB-251570 is the identifier assigned to this vulnerability.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2016-15037?

It affects 1 product.


Products: Go4rayyan Scumblr.

## How do I fix CVE-2016-15037?

No fix has been published for CVE-2016-15037 yet. Limit exposure of the affected software until one is available.

## Is CVE-2016-15037 being exploited?

There is no known exploitation of CVE-2016-15037 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-15037 and fix it if it is affected.

What it is: CVE-2016-15037 is a low-severity cross-site scripting vulnerability in go4rayyan Scumblr, published on 21 Jan 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2016-15037 in the wild and no public exploit code.

Affected product: go4rayyan Scumblr. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-15037/ (Markdown: https://insights.sbomify.com/CVE-2016-15037/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-15037
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-15037
- OSV: https://osv.dev/vulnerability/CVE-2016-15037

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-15037/
Summaries are generated and may contain mistakes; the official description above is the record.
