# CVE-2016-1505: Radicale is vulnerable to directory traversal on Windows Filesystem Storage Backend component

> Remote attackers can read or write arbitrary files on Windows systems via crafted paths in the Radicale filesystem storage backend.

- **Severity:** Critical 10.0 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Feb 2016
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-84cw-mxhv-qvv4, PYSEC-2026-512

## What is CVE-2016-1505?

CVE-2016-1505 is a critical path traversal vulnerability in n/a, published on 3 Feb 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The filesystem storage backend in Radicale before 1.1 on Windows allows remote attackers to read or write to arbitrary files via a crafted path, as demonstrated by /c:/file/ignore.

Weakness: CWE-21

## Which versions are affected by CVE-2016-1505?

3 open source packages ship an affected version, including radicale and Radicale. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `radicale` | PyPI | All versions | 1.1 |
| `radicale` | PyPI | All versions | 1.1 |
| `Radicale` | PyPI | All versions | 1.1 |

Products: Radicale Radicale.

## How do I fix CVE-2016-1505?

Upgrade radicale to 1.1 or later.

## Is CVE-2016-1505 being exploited?

There is no known exploitation of CVE-2016-1505 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2015-8747](https://insights.sbomify.com/CVE-2015-8747/): Radicale vulnerable to arbitrary file read or write (critical 10.0)
- [CVE-2017-8342](https://insights.sbomify.com/CVE-2017-8342/): Radicale is vulnerable to timing oracles and simple bruteforce attacks (high 8.1)
- [CVE-2015-8748](https://insights.sbomify.com/CVE-2015-8748/): Radicale regex metacharacters injection in the user name (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-1505 and fix it if it is affected.

What it is: CVE-2016-1505 is a critical path traversal vulnerability in n/a, published on 3 Feb 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-1505 in the wild and no public exploit code.

Affected packages and fixed versions:
- radicale (PyPI): affected all versions; fixed in 1.1
- radicale (PyPI): affected all versions; fixed in 1.1
- Radicale (PyPI): affected all versions; fixed in 1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-1505/ (Markdown: https://insights.sbomify.com/CVE-2016-1505/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-1505
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-1505
- OSV: https://osv.dev/vulnerability/CVE-2016-1505

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-1505/
Summaries are generated and may contain mistakes; the official description above is the record.
