# CVE-2016-1517: Improper Input Validation in OpenCV

> Remote attackers can cause a denial of service via segfaults in OpenCV by exploiting corrupt chunks, affecting applications using the library.

- **Severity:** Medium 5.5 (`CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Apr 2017
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2016-1517, GHSA-fffj-9qwg-qmh5, PYSEC-2026-2817, PYSEC-2026-708, UBUNTU-CVE-2016-1517

## What is CVE-2016-1517?

CVE-2016-1517 is a medium-severity denial of service vulnerability in OpenCV 3.0.0, published on 10 Apr 2017. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

OpenCV 3.0.0 allows remote attackers to cause a denial of service (segfault) via vectors involving corrupt chunks.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2016-1517?

6 open source packages ship an affected version, including opencv-contrib-python and opencv-python. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `opencv-contrib-python` | PyPI | All versions | 3.3.1.11 |
| `opencv-contrib-python` | PyPI | All versions | 3.3.1.11 |
| `opencv-contrib-python` | PyPI | All versions | 3.3.1.11 |
| `opencv-python` | PyPI | All versions | 3.3.1.11 |
| `opencv-python` | PyPI | All versions | 3.3.1.11 |
| `opencv-python` | PyPI | All versions | 3.3.1.11 |

Products: Opencv Opencv.

## How do I fix CVE-2016-1517?

Upgrade opencv-contrib-python to 3.3.1.11 or later.

## Is CVE-2016-1517 being exploited?

There is no known exploitation of CVE-2016-1517 in the wild and no public exploit code.

## Other vulnerabilities in OpenCV 3.0.0

- [CVE-2019-5063](https://insights.sbomify.com/CVE-2019-5063/): Out-of-bounds Write in OpenCV (high 8.8)
- [CVE-2019-5064](https://insights.sbomify.com/CVE-2019-5064/): Out-of-bounds Write in OpenCV (high 8.8)
- [CVE-2019-14491](https://insights.sbomify.com/CVE-2019-14491/): Out-of-bounds Read in OpenCV (high 8.2)
- [CVE-2019-14492](https://insights.sbomify.com/CVE-2019-14492/): Out-of-bounds Read and Out-of-bounds Write in OpenCV (high 7.5)
- [CVE-2018-7712](https://insights.sbomify.com/CVE-2018-7712/): Denial of service in n/a (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-1517 and fix it if it is affected.

What it is: CVE-2016-1517 is a medium-severity denial of service vulnerability in OpenCV 3.0.0, published on 10 Apr 2017. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2016-1517 in the wild and no public exploit code.

Affected packages and fixed versions:
- opencv-contrib-python (PyPI): affected all versions; fixed in 3.3.1.11
- opencv-contrib-python (PyPI): affected all versions; fixed in 3.3.1.11
- opencv-contrib-python (PyPI): affected all versions; fixed in 3.3.1.11
- opencv-python (PyPI): affected all versions; fixed in 3.3.1.11
- opencv-python (PyPI): affected all versions; fixed in 3.3.1.11
- opencv-python (PyPI): affected all versions; fixed in 3.3.1.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-1517/ (Markdown: https://insights.sbomify.com/CVE-2016-1517/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-1517
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-1517
- OSV: https://osv.dev/vulnerability/CVE-2016-1517

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-1517/
Summaries are generated and may contain mistakes; the official description above is the record.
