{"answers":{"affected":"It affects 2 products.","exploited":"There is no known exploitation of CVE-2016-1544 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2016-1544 is a low-severity denial of service vulnerability in Fedoraproject Fedora, published on 6 Feb 2020. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-1544 and fix it if it is affected.\n\nWhat it is: CVE-2016-1544 is a low-severity denial of service vulnerability in Fedoraproject Fedora, published on 6 Feb 2020. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2016-1544 in the wild and no public exploit code.\n\nAffected product: Fedoraproject Fedora. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-1544/ (Markdown: https://insights.sbomify.com/CVE-2016-1544/index.md)","id":"CVE-2016-1544","markdown":"https://insights.sbomify.com/CVE-2016-1544/index.md","name":"CVE-2016-1544","record":{"aliases":["DEBIAN-CVE-2016-1544","GHSA-32wx-5655-89rw","openSUSE-SU-2024:10164-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"HTTP/2 library","requires_auth":"low_privilege","summary":"Remote attackers can cause memory exhaustion leading to denial of service in the nghttp2 library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"certcc","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"nghttp2","vendor":"nghttp2"}],"cvss":{"score":3.3,"severity":"low","source":"nvd","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"nghttp2 before 1.7.1 allows remote attackers to cause a denial of service (memory exhaustion).","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service in nghttp2","id":"CVE-2016-1544","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"fedoraproject:fedora","products":["fedoraproject:fedora"],"type":"denial_of_service","year":"2016"},"n_packages":1,"n_references":6,"next":{"headline":"Denial of service in n/a","id":"CVE-2016-1546"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.17.0-1.1"],"introduced":["0"],"last_affected":[],"package":"nghttp2","purl":"pkg:rpm/opensuse/nghttp2\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:10164-1"}],"prev":{"headline":"Auth bypass in n/a","id":"CVE-2016-1543"},"products":["nghttp2"],"published":"2020-02-06","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["nghttp2"]},"summary":"Remote attackers can cause memory exhaustion leading to denial of service in the nghttp2 library.","url":"https://insights.sbomify.com/CVE-2016-1544/"}