# CVE-2016-1906: Authorization bypass in Openshift

> Attackers can escalate privileges by modifying build configurations to use disallowed types, compromising the OpenShift container platform.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Feb 2016
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-m3fm-h5jp-q79p, GO-2022-0854, MINI-338h-vwfx-f4qq, MINI-78mf-m7pv-6f6c, MINI-923f-mw3p-wxgg, MINI-9fwj-xccx-vq48, MINI-c753-77x9-6h9v, MINI-chh6-9r7f-cr93, MINI-g3cr-fr7v-3vwp, MINI-hrvr-c39m-vc8r, MINI-mf9m-6p8h-63f9, MINI-mrq9-4cwf-x8w8, MINI-pr7h-3c9f-cq4r, MINI-v829-phv8-wpw2

## What is CVE-2016-1906?

CVE-2016-1906 is a critical vulnerability in Kubernetes Kubernetes, published on 3 Feb 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Openshift allows remote attackers to gain privileges by updating a build configuration that was created with an allowed type to a type that is not allowed.

Weakness: CWE-264

## Which versions are affected by CVE-2016-1906?

3 open source packages ship an affected version, including github.com/openshift/origin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/openshift/origin` | Go | All versions | 1.1.1 |
| `github.com/openshift/origin` | Go | All versions | 1.1.1 |
| `github.com/openshift/origin` | Go | All versions | 1.1.1 |

Products: Kubernetes Kubernetes.

## How do I fix CVE-2016-1906?

Upgrade github.com/openshift/origin to 1.1.1 or later.

## Is CVE-2016-1906 being exploited?

There is no known exploitation of CVE-2016-1906 in the wild and no public exploit code.

## Other vulnerabilities in Kubernetes Kubernetes

- [CVE-2018-1002105](https://insights.sbomify.com/CVE-2018-1002105/): Privilege Escalation in Kubernetes (critical 9.8)
- [CVE-2017-1000056](https://insights.sbomify.com/CVE-2017-1000056/): Kubernetes Privilege Escalation (critical 9.8)
- [CVE-2023-3676](https://insights.sbomify.com/CVE-2023-3676/): Kubernetes - Windows nodes - Insufficient input sanitization leads to privilege escalation (high 8.8)
- [CVE-2023-3955](https://insights.sbomify.com/CVE-2023-3955/): Kubernetes - Windows nodes - Insufficient input sanitization leads to privilege escalation (high 8.8)
- [CVE-2021-25741](https://insights.sbomify.com/CVE-2021-25741/): Symlink Exchange Can Allow Host Filesystem Access (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-1906 and fix it if it is affected.

What it is: CVE-2016-1906 is a critical vulnerability in Kubernetes Kubernetes, published on 3 Feb 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-1906 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/openshift/origin (Go): affected all versions; fixed in 1.1.1
- github.com/openshift/origin (Go): affected all versions; fixed in 1.1.1
- github.com/openshift/origin (Go): affected all versions; fixed in 1.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-1906/ (Markdown: https://insights.sbomify.com/CVE-2016-1906/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-1906
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-1906
- OSV: https://osv.dev/vulnerability/CVE-2016-1906

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-1906/
Summaries are generated and may contain mistakes; the official description above is the record.
