CVE-2016-1927 phpMyAdmin Cryptographic Vulnerability
phpMyAdmin uses weak random number generation for password suggestions, allowing attackers to guess passwords via brute-force attacks.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2016-1927?
CVE-2016-1927 is a high-severity vulnerability in Phpmyadmin Phpmyadmin, published on 20 Feb 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The suggestPassword function in js/functions.js in phpMyAdmin 4.0.x before 4.0.10.13, 4.4.x before 4.4.15.3, and 4.5.x before 4.5.4 relies on the Math.random JavaScript function, which makes it easier for remote attackers to guess passwords via a brute-force approach.
Which versions are affected by CVE-2016-1927?
6 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
phpmyadmin/phpmyadmin Packagist | From 4.0.0 | 4.0.10.13 |
phpmyadmin/phpmyadmin Packagist | From 4.0.0 | 4.0.10.13 |
phpmyadmin/phpmyadmin Packagist | From 4.4.0 | 4.4.15.3 |
phpmyadmin/phpmyadmin Packagist | From 4.4.0 | 4.4.15.3 |
phpmyadmin/phpmyadmin Packagist | From 4.5.0 | 4.5.4 |
phpmyadmin/phpmyadmin Packagist | From 4.5.0 | 4.5.4 |
Products include Phpmyadmin Phpmyadmin.
How do I fix CVE-2016-1927?
Upgrade phpmyadmin/phpmyadmin to a fixed version for your release line: 4.0.10.13, 4.4.15.3 or 4.5.4.
Is CVE-2016-1927 being exploited?
There is no known exploitation of CVE-2016-1927 in the wild and no public exploit code.
Other vulnerabilities in Phpmyadmin Phpmyadmin
Sources
Also known as DEBIAN-CVE-2016-1927, GHSA-4gmg-gwjh-3mmr, UBUNTU-CVE-2016-1927.