# CVE-2016-20018: Knex.js has a limited SQL injection vulnerability

> Attackers can exploit a SQL injection flaw in Knex.js to bypass WHERE clauses, potentially reading or modifying database records.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Dec 2022
- **Updated:** 6 Aug 2024
- **Also known as:** CLEANSTART-2026-MA00525, CLSA-2026-1774830252, CVE-2023-22494, GHSA-4jv9-3563-23j3, ROOT-APP-NPM-CVE-2016-20018

## What is CVE-2016-20018?

CVE-2016-20018 is a high-severity SQL injection vulnerability in n/a, published on 19 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Knex Knex.js through 2.3.0 has a limited SQL injection vulnerability that can be exploited to ignore the WHERE clause of a SQL query.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2016-20018?

2 open source packages ship an affected version, including knex. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `knex` | npm | All versions | 2.4.0 |
| `knex` | npm | All versions | 2.4.0 |

Products: Knexjs Knex.

## How do I fix CVE-2016-20018?

Upgrade knex to 2.4.0 or later.

## Is CVE-2016-20018 being exploited?

There is no known exploitation of CVE-2016-20018 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2019-10757](https://insights.sbomify.com/CVE-2019-10757/): SQL Injection in knex (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-20018 and fix it if it is affected.

What it is: CVE-2016-20018 is a high-severity SQL injection vulnerability in n/a, published on 19 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-20018 in the wild and no public exploit code.

Affected packages and fixed versions:
- knex (npm): affected all versions; fixed in 2.4.0
- knex (npm): affected all versions; fixed in 2.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-20018/ (Markdown: https://insights.sbomify.com/CVE-2016-20018/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-20018
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-20018
- OSV: https://osv.dev/vulnerability/CVE-2016-20018

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-20018/
Summaries are generated and may contain mistakes; the official description above is the record.
