{"answers":{"affected":"3 open source packages ship an affected version, including portage. It affects 1 product.","exploited":"There is no known exploitation of CVE-2016-20021 in the wild and no public exploit code.","fix":"Upgrade portage to 3.0.47 or later.","what":"CVE-2016-20021 is a critical vulnerability in n/a, published on 12 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-20021 and fix it if it is affected.\n\nWhat it is: CVE-2016-20021 is a critical vulnerability in n/a, published on 12 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2016-20021 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- portage (PyPI): affected all versions; fixed in 3.0.47\n- portage (PyPI): affected all versions; fixed in 3.0.47\n- portage (PyPI): affected all versions; fixed in 3.0.47\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-20021/ (Markdown: https://insights.sbomify.com/CVE-2016-20021/index.md)","id":"CVE-2016-20021","markdown":"https://insights.sbomify.com/CVE-2016-20021/index.md","name":"CVE-2016-20021","record":{"aliases":["GHSA-pw5x-x5jw-ccmh","PYSEC-2024-10"],"analysis":{"component_type":"operating_system","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Gentoo package manager","requires_auth":"none","summary":"Attackers can execute arbitrary code via emerge-webrsync because it fails to verify PGP signatures on downloaded files.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"portage","vendor":"gentoo"}],"cvss":{"score":9.8,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-347","name":"Improper Verification of Cryptographic Signature"}],"description":"In Gentoo Portage before 3.0.47, there is missing PGP validation of executed code: the standalone emerge-webrsync downloads a .gpgsig file but does not perform signature verification. Unless emerge-webrsync is used, Portage is not vulnerable.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Gentoo Portage missing PGP validation of executed code","id":"CVE-2016-20021","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"security_feature_bypass","year":"2016"},"n_packages":3,"n_references":3,"next":{"headline":"Memory corruption in n/a","id":"CVE-2016-20022"},"packages":[{"ecosystem":"PyPI","fixed":["3.0.47"],"introduced":["0"],"last_affected":[],"package":"portage","purl":null,"source":"GHSA-pw5x-x5jw-ccmh"},{"ecosystem":"PyPI","fixed":["3.0.47"],"introduced":["0"],"last_affected":[],"package":"portage","purl":"pkg:pypi/portage","source":"GHSA-pw5x-x5jw-ccmh"},{"ecosystem":"PyPI","fixed":["3.0.47"],"introduced":["0"],"last_affected":[],"package":"portage","purl":"pkg:pypi/portage","source":"PYSEC-2024-10"}],"prev":{"headline":"Knex.js has a limited SQL injection vulnerability","id":"CVE-2016-20018"},"products":["n/a"],"published":"2024-01-12","related":[{"cvss_score":9.3,"headline":"Gentoo Portage does not verify X.509 certificates from SSL servers","id":"CVE-2013-2100","kev_date_added":null,"published":"2014-09-29"},{"cvss_score":7.1,"headline":"Privilege escalation in n/a","id":"CVE-2004-2778","kev_date_added":null,"published":"2017-06-27"},{"cvss_score":6.9,"headline":"Path traversal in n/a","id":"CVE-2008-4394","kev_date_added":null,"published":"2008-10-10"},{"cvss_score":5.5,"headline":"Race condition in n/a","id":"CVE-2019-20384","kev_date_added":null,"published":"2020-01-20"},{"cvss_score":2.1,"headline":"Information disclosure in n/a","id":"CVE-2007-6249","kev_date_added":null,"published":"2007-12-15"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-06-03","vendors":["n/a"]},"summary":"Attackers can execute arbitrary code via emerge-webrsync because it fails to verify PGP signatures on downloaded files.","url":"https://insights.sbomify.com/CVE-2016-20021/"}