CVE-2016-2040 phpMyAdmin XSS Vulnerability

Medium 5.4 Published Updated

Authenticated attackers can inject arbitrary scripts via table names, search queries, or hostnames, potentially compromising user sessions in phpMyAdmin.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2016-2040?

CVE-2016-2040 is a medium-severity cross-site scripting vulnerability in Fedoraproject Fedora, published on 20 Feb 2016. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin 4.0.x before 4.0.10.13, 4.4.x before 4.4.15.3, and 4.5.x before 4.5.4 allow remote authenticated users to inject arbitrary web script or HTML via a (1) table name, (2) SET value, (3) search query, or (4) hostname in a Location header.

Weakness: CWE-79

Which versions are affected by CVE-2016-2040?

6 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 4 products.

PackageAffectedFixed in
phpmyadmin/phpmyadmin PackagistFrom 4.04.0.10.13
phpmyadmin/phpmyadmin PackagistFrom 4.04.0.10.13
phpmyadmin/phpmyadmin PackagistFrom 4.44.4.15.3
phpmyadmin/phpmyadmin PackagistFrom 4.44.4.15.3
phpmyadmin/phpmyadmin PackagistFrom 4.54.5.4
phpmyadmin/phpmyadmin PackagistFrom 4.54.5.4

Products include Fedoraproject Fedora, Opensuse Leap, Opensuse Opensuse, Phpmyadmin Phpmyadmin.

How do I fix CVE-2016-2040?

Upgrade phpmyadmin/phpmyadmin to a fixed version for your release line: 4.0.10.13, 4.4.15.3 or 4.5.4.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2016-2040 being exploited?

There is no known exploitation of CVE-2016-2040 in the wild and no public exploit code.

All Fedoraproject Fedora vulnerabilities

Sources

Also known as DEBIAN-CVE-2016-2040, GHSA-pw34-qf6c-84fc, UBUNTU-CVE-2016-2040.

Is CVE-2016-2040 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free