# CVE-2016-2040: phpMyAdmin XSS Vulnerability

> Authenticated attackers can inject arbitrary scripts via table names, search queries, or hostnames, potentially compromising user sessions in phpMyAdmin.

- **Severity:** Medium 5.4 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 Feb 2016
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2016-2040, GHSA-pw34-qf6c-84fc, UBUNTU-CVE-2016-2040

## What is CVE-2016-2040?

CVE-2016-2040 is a medium-severity cross-site scripting vulnerability in Fedoraproject Fedora, published on 20 Feb 2016. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin 4.0.x before 4.0.10.13, 4.4.x before 4.4.15.3, and 4.5.x before 4.5.4 allow remote authenticated users to inject arbitrary web script or HTML via a (1) table name, (2) SET value, (3) search query, or (4) hostname in a Location header.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2016-2040?

6 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.0 | 4.0.10.13 |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.0 | 4.0.10.13 |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.4 | 4.4.15.3 |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.4 | 4.4.15.3 |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.5 | 4.5.4 |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.5 | 4.5.4 |

Products: Fedoraproject Fedora, Opensuse Leap, Opensuse Opensuse, Phpmyadmin Phpmyadmin.

## How do I fix CVE-2016-2040?

Upgrade phpmyadmin/phpmyadmin to a fixed version for your release line: 4.0.10.13, 4.4.15.3 or 4.5.4.

## Is CVE-2016-2040 being exploited?

There is no known exploitation of CVE-2016-2040 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-2040 and fix it if it is affected.

What it is: CVE-2016-2040 is a medium-severity cross-site scripting vulnerability in Fedoraproject Fedora, published on 20 Feb 2016. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2016-2040 in the wild and no public exploit code.

Affected packages and fixed versions:
- phpmyadmin/phpmyadmin (Packagist): affected from 4.0; fixed in 4.0.10.13
- phpmyadmin/phpmyadmin (Packagist): affected from 4.0; fixed in 4.0.10.13
- phpmyadmin/phpmyadmin (Packagist): affected from 4.4; fixed in 4.4.15.3
- phpmyadmin/phpmyadmin (Packagist): affected from 4.4; fixed in 4.4.15.3
- phpmyadmin/phpmyadmin (Packagist): affected from 4.5; fixed in 4.5.4
- phpmyadmin/phpmyadmin (Packagist): affected from 4.5; fixed in 4.5.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-2040/ (Markdown: https://insights.sbomify.com/CVE-2016-2040/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-2040
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-2040
- OSV: https://osv.dev/vulnerability/CVE-2016-2040

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-2040/
Summaries are generated and may contain mistakes; the official description above is the record.
