CVE-2016-2041 phpMyAdmin Unsafe comparison of XSRF/CSRF token
Remote attackers can bypass CSRF protections in phpMyAdmin by exploiting timing side-channels in token comparison, allowing unauthorized actions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2016-2041?
CVE-2016-2041 is a high-severity vulnerability in Fedoraproject Fedora, published on 20 Feb 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
libraries/common.inc.php in phpMyAdmin 4.0.x before 4.0.10.13, 4.4.x before 4.4.15.3, and 4.5.x before 4.5.4 does not use a constant-time algorithm for comparing CSRF tokens, which makes it easier for remote attackers to bypass intended access restrictions by measuring time differences.
Weakness: CWE-254
Which versions are affected by CVE-2016-2041?
6 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 4 products.
| Package | Affected | Fixed in |
|---|---|---|
phpmyadmin/phpmyadmin Packagist | From 4.0 | 4.0.10.13 |
phpmyadmin/phpmyadmin Packagist | From 4.0 | 4.0.10.13 |
phpmyadmin/phpmyadmin Packagist | From 4.4 | 4.4.15.3 |
phpmyadmin/phpmyadmin Packagist | From 4.4 | 4.4.15.3 |
phpmyadmin/phpmyadmin Packagist | From 4.5 | 4.5.4 |
phpmyadmin/phpmyadmin Packagist | From 4.5 | 4.5.4 |
Products include Fedoraproject Fedora, Opensuse Leap, Opensuse Opensuse, Phpmyadmin Phpmyadmin.
How do I fix CVE-2016-2041?
Upgrade phpmyadmin/phpmyadmin to a fixed version for your release line: 4.0.10.13, 4.4.15.3 or 4.5.4.
Is CVE-2016-2041 being exploited?
There is no known exploitation of CVE-2016-2041 in the wild and no public exploit code.
Other vulnerabilities in Fedoraproject Fedora
Sources
Also known as DEBIAN-CVE-2016-2041, GHSA-8m97-xc46-rw9w, UBUNTU-CVE-2016-2041.