{"answers":{"affected":"6 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 4 products.","exploited":"There is no known exploitation of CVE-2016-2041 in the wild and no public exploit code.","fix":"Upgrade phpmyadmin/phpmyadmin to a fixed version for your release line: 4.0.10.13, 4.4.15.3 or 4.5.4.","what":"CVE-2016-2041 is a high-severity vulnerability in Fedoraproject Fedora, published on 20 Feb 2016. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-2041 and fix it if it is affected.\n\nWhat it is: CVE-2016-2041 is a high-severity vulnerability in Fedoraproject Fedora, published on 20 Feb 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2016-2041 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- phpmyadmin/phpmyadmin (Packagist): affected from 4.0; fixed in 4.0.10.13\n- phpmyadmin/phpmyadmin (Packagist): affected from 4.0; fixed in 4.0.10.13\n- phpmyadmin/phpmyadmin (Packagist): affected from 4.4; fixed in 4.4.15.3\n- phpmyadmin/phpmyadmin (Packagist): affected from 4.4; fixed in 4.4.15.3\n- phpmyadmin/phpmyadmin (Packagist): affected from 4.5; fixed in 4.5.4\n- phpmyadmin/phpmyadmin (Packagist): affected from 4.5; fixed in 4.5.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-2041/ (Markdown: https://insights.sbomify.com/CVE-2016-2041/index.md)","id":"CVE-2016-2041","markdown":"https://insights.sbomify.com/CVE-2016-2041/index.md","name":"CVE-2016-2041","record":{"aliases":["DEBIAN-CVE-2016-2041","GHSA-8m97-xc46-rw9w","UBUNTU-CVE-2016-2041"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"phpMyAdmin","requires_auth":"none","summary":"Remote attackers can bypass CSRF protections in phpMyAdmin by exploiting timing side-channels in token comparison, allowing unauthorized actions.","user_interaction":"not_required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"leap","vendor":"opensuse"},{"product":"opensuse","vendor":"opensuse"},{"product":"phpmyadmin","vendor":"phpmyadmin"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.0"},"cwes":[{"id":"CWE-254","name":null}],"description":"libraries/common.inc.php in phpMyAdmin 4.0.x before 4.0.10.13, 4.4.x before 4.4.15.3, and 4.5.x before 4.5.4 does not use a constant-time algorithm for comparing CSRF tokens, which makes it easier for remote attackers to bypass intended access restrictions by measuring time differences.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"phpMyAdmin Unsafe comparison of XSRF/CSRF token","id":"CVE-2016-2041","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"fedoraproject:fedora","products":["fedoraproject:fedora","opensuse:leap","opensuse:opensuse","phpmyadmin:phpmyadmin"],"type":"csrf","year":"2016"},"n_packages":6,"n_references":7,"next":{"headline":"Information disclosure in n/a","id":"CVE-2016-2042"},"packages":[{"ecosystem":"Packagist","fixed":["4.0.10.13"],"introduced":["4.0"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":null,"source":"GHSA-8m97-xc46-rw9w"},{"ecosystem":"Packagist","fixed":["4.0.10.13"],"introduced":["4.0"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":"pkg:composer/phpmyadmin/phpmyadmin","source":"GHSA-8m97-xc46-rw9w"},{"ecosystem":"Packagist","fixed":["4.4.15.3"],"introduced":["4.4"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":null,"source":"GHSA-8m97-xc46-rw9w"},{"ecosystem":"Packagist","fixed":["4.4.15.3"],"introduced":["4.4"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":"pkg:composer/phpmyadmin/phpmyadmin","source":"GHSA-8m97-xc46-rw9w"},{"ecosystem":"Packagist","fixed":["4.5.4"],"introduced":["4.5"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":null,"source":"GHSA-8m97-xc46-rw9w"},{"ecosystem":"Packagist","fixed":["4.5.4"],"introduced":["4.5"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":"pkg:composer/phpmyadmin/phpmyadmin","source":"GHSA-8m97-xc46-rw9w"}],"prev":{"headline":"phpMyAdmin XSS Vulnerability","id":"CVE-2016-2040"},"products":["n/a"],"published":"2016-02-20","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Remote attackers can bypass CSRF protections in phpMyAdmin by exploiting timing side-channels in token comparison, allowing unauthorized actions.","url":"https://insights.sbomify.com/CVE-2016-2041/"}