# CVE-2016-2041: phpMyAdmin Unsafe comparison of XSRF/CSRF token

> Remote attackers can bypass CSRF protections in phpMyAdmin by exploiting timing side-channels in token comparison, allowing unauthorized actions.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Feb 2016
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2016-2041, GHSA-8m97-xc46-rw9w, UBUNTU-CVE-2016-2041

## What is CVE-2016-2041?

CVE-2016-2041 is a high-severity vulnerability in Fedoraproject Fedora, published on 20 Feb 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

libraries/common.inc.php in phpMyAdmin 4.0.x before 4.0.10.13, 4.4.x before 4.4.15.3, and 4.5.x before 4.5.4 does not use a constant-time algorithm for comparing CSRF tokens, which makes it easier for remote attackers to bypass intended access restrictions by measuring time differences.

Weakness: CWE-254

## Which versions are affected by CVE-2016-2041?

6 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.0 | 4.0.10.13 |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.0 | 4.0.10.13 |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.4 | 4.4.15.3 |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.4 | 4.4.15.3 |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.5 | 4.5.4 |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.5 | 4.5.4 |

Products: Fedoraproject Fedora, Opensuse Leap, Opensuse Opensuse, Phpmyadmin Phpmyadmin.

## How do I fix CVE-2016-2041?

Upgrade phpmyadmin/phpmyadmin to a fixed version for your release line: 4.0.10.13, 4.4.15.3 or 4.5.4.

## Is CVE-2016-2041 being exploited?

There is no known exploitation of CVE-2016-2041 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-2041 and fix it if it is affected.

What it is: CVE-2016-2041 is a high-severity vulnerability in Fedoraproject Fedora, published on 20 Feb 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-2041 in the wild and no public exploit code.

Affected packages and fixed versions:
- phpmyadmin/phpmyadmin (Packagist): affected from 4.0; fixed in 4.0.10.13
- phpmyadmin/phpmyadmin (Packagist): affected from 4.0; fixed in 4.0.10.13
- phpmyadmin/phpmyadmin (Packagist): affected from 4.4; fixed in 4.4.15.3
- phpmyadmin/phpmyadmin (Packagist): affected from 4.4; fixed in 4.4.15.3
- phpmyadmin/phpmyadmin (Packagist): affected from 4.5; fixed in 4.5.4
- phpmyadmin/phpmyadmin (Packagist): affected from 4.5; fixed in 4.5.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-2041/ (Markdown: https://insights.sbomify.com/CVE-2016-2041/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-2041
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-2041
- OSV: https://osv.dev/vulnerability/CVE-2016-2041

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-2041/
Summaries are generated and may contain mistakes; the official description above is the record.
