# CVE-2016-2097: actionview contains Path Traversal vulnerability

> Remote attackers can read arbitrary files by exploiting a directory traversal flaw in Ruby on Rails' render method when unrestricted use is enabled.

- **Severity:** Medium 5.3 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Apr 2016
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2016-2097, GHSA-vx9j-46rh-fqr8

## What is CVE-2016-2097?

CVE-2016-2097 is a medium-severity path traversal vulnerability in Rubyonrails Rails, published on 7 Apr 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Directory traversal vulnerability in Action View in Ruby on Rails before 3.2.22.2 and 4.x before 4.1.14.2 allows remote attackers to read arbitrary files by leveraging an application's unrestricted use of the render method and providing a .. (dot dot) in a pathname.  NOTE: this vulnerability exists because of an incomplete fix for CVE-2016-0752.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2016-2097?

8 open source packages ship an affected version, including actionpack and actionview. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `actionpack` | RubyGems | From 3.0.0 | 3.2.22.2 |
| `actionpack` | RubyGems | From 3.0.0 | 3.2.22.2 |
| `actionpack` | RubyGems | From 4.0.0 | 4.1.14.2 |
| `actionpack` | RubyGems | From 4.0.0 | 4.1.14.2 |
| `actionview` | RubyGems | From 3.0.0 | 3.2.22.2 |
| `actionview` | RubyGems | From 3.0.0 | 3.2.22.2 |
| `actionview` | RubyGems | From 4.0.0 | 4.1.14.2 |
| `actionview` | RubyGems | From 4.0.0 | 4.1.14.2 |

Products: Rubyonrails Rails, Rubyonrails Ruby on Rails.

## How do I fix CVE-2016-2097?

Upgrade actionpack to a fixed version for your release line: 3.2.22.2 or 4.1.14.2.

## Is CVE-2016-2097 being exploited?

There is no known exploitation of CVE-2016-2097 in the wild and no public exploit code.

## Other vulnerabilities in Rubyonrails Rails

- [CVE-2013-0277](https://insights.sbomify.com/CVE-2013-0277/): Active Record contains deserialization of arbitrary YAML (critical 10.0)
- [CVE-2017-17916](https://insights.sbomify.com/CVE-2017-17916/): SQL injection in n/a (high 8.1)
- [CVE-2017-17917](https://insights.sbomify.com/CVE-2017-17917/): SQL injection in n/a (high 8.1)
- [CVE-2026-33195](https://insights.sbomify.com/CVE-2026-33195/): Rails Active Storage has possible Path Traversal in DiskService (high 8.0)
- [CVE-2024-26142](https://insights.sbomify.com/CVE-2024-26142/): Rails possible ReDoS vulnerability in Accept header parsing in Action Dispatch (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-2097 and fix it if it is affected.

What it is: CVE-2016-2097 is a medium-severity path traversal vulnerability in Rubyonrails Rails, published on 7 Apr 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-2097 in the wild and no public exploit code.

Affected packages and fixed versions:
- actionpack (RubyGems): affected from 3.0.0; fixed in 3.2.22.2
- actionpack (RubyGems): affected from 3.0.0; fixed in 3.2.22.2
- actionpack (RubyGems): affected from 4.0.0; fixed in 4.1.14.2
- actionpack (RubyGems): affected from 4.0.0; fixed in 4.1.14.2
- actionview (RubyGems): affected from 3.0.0; fixed in 3.2.22.2
- actionview (RubyGems): affected from 3.0.0; fixed in 3.2.22.2
- actionview (RubyGems): affected from 4.0.0; fixed in 4.1.14.2
- actionview (RubyGems): affected from 4.0.0; fixed in 4.1.14.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-2097/ (Markdown: https://insights.sbomify.com/CVE-2016-2097/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-2097
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-2097
- OSV: https://osv.dev/vulnerability/CVE-2016-2097

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-2097/
Summaries are generated and may contain mistakes; the official description above is the record.
