CVE-2016-2155 Moodle allows attackers to modify "Exclude grade" settings

Medium 4.3 Published Updated

Authenticated users with Non-Editing Instructor role can modify grade exclusion settings due to missing capability checks in Moodle.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2016-2155?

CVE-2016-2155 is a medium-severity missing authorization vulnerability in Moodle Moodle, published on 22 May 2016. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

The grade-reporting feature in Singleview (aka Single View) in Moodle 2.8.x before 2.8.11, 2.9.x before 2.9.5, and 3.0.x before 3.0.3 does not consider the moodle/grade:manage capability, which allows remote authenticated users to modify "Exclude grade" settings by leveraging the Non-Editing Instructor role.

Weakness: CWE-264

Which versions are affected by CVE-2016-2155?

6 open source packages ship an affected version, including moodle/moodle. It affects 1 product.

PackageAffectedFixed in
moodle/moodle PackagistFrom 2.8.02.8.11
moodle/moodle PackagistFrom 2.8.02.8.11
moodle/moodle PackagistFrom 2.9.02.9.5
moodle/moodle PackagistFrom 2.9.02.9.5
moodle/moodle PackagistFrom 3.0.03.0.3
moodle/moodle PackagistFrom 3.0.03.0.3

Products include Moodle Moodle.

How do I fix CVE-2016-2155?

Upgrade moodle/moodle to a fixed version for your release line: 2.8.11, 2.9.5 or 3.0.3.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2016-2155 being exploited?

There is no known exploitation of CVE-2016-2155 in the wild and no public exploit code.

All Moodle Moodle vulnerabilities

Sources

Also known as GHSA-32hg-73hp-vwc8, UBUNTU-CVE-2016-2155.

Is CVE-2016-2155 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free