CVE-2016-2157 Moodle cross-site request forgery (CSRF) vulnerability
Remote attackers can hijack administrator sessions to manage Assignment plugins in Moodle via CSRF.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2016-2157?
CVE-2016-2157 is a high-severity vulnerability in Moodle Moodle, published on 22 May 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Cross-site request forgery (CSRF) vulnerability in mod/assign/adminmanageplugins.php in Moodle through 2.6.11, 2.7.x before 2.7.13, 2.8.x before 2.8.11, 2.9.x before 2.9.5, and 3.0.x before 3.0.3 allows remote attackers to hijack the authentication of administrators for requests that manage Assignment plugins.
Weakness: CWE-352
Which versions are affected by CVE-2016-2157?
8 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 2.7.13 |
moodle/moodle Packagist | All versions | 2.7.13 |
moodle/moodle Packagist | From 2.8.0 | 2.8.11 |
moodle/moodle Packagist | From 2.8.0 | 2.8.11 |
moodle/moodle Packagist | From 2.9.0 | 2.9.5 |
moodle/moodle Packagist | From 2.9.0 | 2.9.5 |
2 more packages
moodle/moodle Packagist | From 3.0.0 | 3.0.3 |
moodle/moodle Packagist | From 3.0.0 | 3.0.3 |
Products include Moodle Moodle.
How do I fix CVE-2016-2157?
Upgrade moodle/moodle to a fixed version for your release line: 2.7.13, 2.8.11, 2.9.5 or 3.0.3.
Is CVE-2016-2157 being exploited?
There is no known exploitation of CVE-2016-2157 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-f5pm-c4cw-563p, UBUNTU-CVE-2016-2157.