CVE-2016-2158 Moodle allows attackers to obtain sensitive category-detail information
Remote attackers with guest access can obtain sensitive category details via an Ajax request when the forcelogin feature is enabled.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2016-2158?
CVE-2016-2158 is a medium-severity vulnerability in Moodle Moodle, published on 22 May 2016. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
lib/ajax/getnavbranch.php in Moodle through 2.6.11, 2.7.x before 2.7.13, 2.8.x before 2.8.11, 2.9.x before 2.9.5, and 3.0.x before 3.0.3, when the forcelogin feature is enabled, allows remote attackers to obtain sensitive category-detail information from the navigation branch by leveraging the guest role for an Ajax request.
Weakness: CWE-200
Which versions are affected by CVE-2016-2158?
8 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 2.7.13 |
moodle/moodle Packagist | All versions | 2.7.13 |
moodle/moodle Packagist | From 2.8.0 | 2.8.11 |
moodle/moodle Packagist | From 2.8.0 | 2.8.11 |
moodle/moodle Packagist | From 2.9.0 | 2.9.5 |
moodle/moodle Packagist | From 2.9.0 | 2.9.5 |
2 more packages
moodle/moodle Packagist | From 3.0.0 | 3.0.3 |
moodle/moodle Packagist | From 3.0.0 | 3.0.3 |
Products include Moodle Moodle.
How do I fix CVE-2016-2158?
Upgrade moodle/moodle to a fixed version for your release line: 2.7.13, 2.8.11, 2.9.5 or 3.0.3.
Is CVE-2016-2158 being exploited?
There is no known exploitation of CVE-2016-2158 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-m882-j7gq-v9p7, UBUNTU-CVE-2016-2158.