{"answers":{"affected":"8 open source packages ship an affected version, including moodle/moodle. It affects 1 product.","exploited":"There is no known exploitation of CVE-2016-2158 in the wild and no public exploit code.","fix":"Upgrade moodle/moodle to a fixed version for your release line: 2.7.13, 2.8.11, 2.9.5 or 3.0.3.","what":"CVE-2016-2158 is a medium-severity vulnerability in Moodle Moodle, published on 22 May 2016. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-2158 and fix it if it is affected.\n\nWhat it is: CVE-2016-2158 is a medium-severity vulnerability in Moodle Moodle, published on 22 May 2016. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2016-2158 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- moodle/moodle (Packagist): affected all versions; fixed in 2.7.13\n- moodle/moodle (Packagist): affected all versions; fixed in 2.7.13\n- moodle/moodle (Packagist): affected from 2.8.0; fixed in 2.8.11\n- moodle/moodle (Packagist): affected from 2.8.0; fixed in 2.8.11\n- moodle/moodle (Packagist): affected from 2.9.0; fixed in 2.9.5\n- moodle/moodle (Packagist): affected from 2.9.0; fixed in 2.9.5\n- moodle/moodle (Packagist): affected from 3.0.0; fixed in 3.0.3\n- moodle/moodle (Packagist): affected from 3.0.0; fixed in 3.0.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-2158/ (Markdown: https://insights.sbomify.com/CVE-2016-2158/index.md)","id":"CVE-2016-2158","markdown":"https://insights.sbomify.com/CVE-2016-2158/index.md","name":"CVE-2016-2158","record":{"aliases":["GHSA-m882-j7gq-v9p7","UBUNTU-CVE-2016-2158"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"Moodle LMS","requires_auth":"low_privilege","summary":"Remote attackers with guest access can obtain sensitive category details via an Ajax request when the forcelogin feature is enabled.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"moodle","vendor":"moodle"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N","version":"3.0"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"lib/ajax/getnavbranch.php in Moodle through 2.6.11, 2.7.x before 2.7.13, 2.8.x before 2.8.11, 2.9.x before 2.9.5, and 3.0.x before 3.0.3, when the forcelogin feature is enabled, allows remote attackers to obtain sensitive category-detail information from the navigation branch by leveraging the guest role for an Ajax request.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Moodle allows attackers to obtain sensitive category-detail information","id":"CVE-2016-2158","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"moodle:moodle","products":["moodle:moodle"],"type":"information_disclosure","year":"2016"},"n_packages":8,"n_references":4,"next":{"headline":"Moodle External function mod_assign_save_submission does not check due dates","id":"CVE-2016-2159"},"packages":[{"ecosystem":"Packagist","fixed":["2.7.13"],"introduced":["0"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-m882-j7gq-v9p7"},{"ecosystem":"Packagist","fixed":["2.7.13"],"introduced":["0"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-m882-j7gq-v9p7"},{"ecosystem":"Packagist","fixed":["2.8.11"],"introduced":["2.8.0"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-m882-j7gq-v9p7"},{"ecosystem":"Packagist","fixed":["2.8.11"],"introduced":["2.8.0"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-m882-j7gq-v9p7"},{"ecosystem":"Packagist","fixed":["2.9.5"],"introduced":["2.9.0"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-m882-j7gq-v9p7"},{"ecosystem":"Packagist","fixed":["2.9.5"],"introduced":["2.9.0"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-m882-j7gq-v9p7"},{"ecosystem":"Packagist","fixed":["3.0.3"],"introduced":["3.0.0"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-m882-j7gq-v9p7"},{"ecosystem":"Packagist","fixed":["3.0.3"],"introduced":["3.0.0"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-m882-j7gq-v9p7"}],"prev":{"headline":"Moodle cross-site request forgery (CSRF) vulnerability","id":"CVE-2016-2157"},"products":["n/a"],"published":"2016-05-22","related":[{"cvss_score":10,"headline":"File upload in n/a","id":"CVE-2006-4935","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Moodle does not properly validate module instance id","id":"CVE-2006-4936","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Unknown \"front page vulnerability with Moodle servers\" for Moodle before 1.3.2 has unknown impact and attack vectors.","id":"CVE-2004-2233","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Cross-site scripting in n/a","id":"CVE-2004-2235","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2004-2236","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Unknown vulnerability in Moodle before 1.3.4 has unknown impact and attack vectors, related to \"strings in Moodle texts.\"","id":"CVE-2004-2237","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Multiple unknown vulnerabilities in Moodle before 1.5.1 have unknown impact and attack vectors.","id":"CVE-2005-2247","kev_date_added":null,"published":"2005-07-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Remote attackers with guest access can obtain sensitive category details via an Ajax request when the forcelogin feature is enabled.","url":"https://insights.sbomify.com/CVE-2016-2158/"}