CVE-2016-2159 Moodle External function mod_assign_save_submission does not check due dates
Authenticated students can bypass assignment due-date restrictions via web-service requests in Moodle, allowing late submissions.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2016-2159?
CVE-2016-2159 is a medium-severity missing authorization vulnerability in Moodle Moodle, published on 22 May 2016. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
The save_submission function in mod/assign/externallib.php in Moodle through 2.6.11, 2.7.x before 2.7.13, 2.8.x before 2.8.11, 2.9.x before 2.9.5, and 3.0.x before 3.0.3 allows remote authenticated users to bypass intended due-date restrictions by leveraging the student role for a web-service request.
Weakness: CWE-284
Which versions are affected by CVE-2016-2159?
8 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 2.7 | 2.7.13 |
moodle/moodle Packagist | From 2.7 | 2.7.13 |
moodle/moodle Packagist | From 2.8 | 2.8.11 |
moodle/moodle Packagist | From 2.8 | 2.8.11 |
moodle/moodle Packagist | From 2.9 | 2.9.5 |
moodle/moodle Packagist | From 2.9 | 2.9.5 |
2 more packages
moodle/moodle Packagist | From 3.0 | 3.0.3 |
moodle/moodle Packagist | From 3.0 | 3.0.3 |
Products include Moodle Moodle.
How do I fix CVE-2016-2159?
Upgrade moodle/moodle to a fixed version for your release line: 2.7.13, 2.8.11, 2.9.5 or 3.0.3.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2016-2159 being exploited?
There is no known exploitation of CVE-2016-2159 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-cw72-69wq-f9f2.