{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.struts:struts2-core. It affects 1 product.","exploited":"There is no known exploitation of CVE-2016-2162 in the wild and no public exploit code.","fix":"Upgrade org.apache.struts:struts2-core to 2.3.28 or later.","what":"CVE-2016-2162 is a medium-severity cross-site scripting vulnerability in Apache Struts, published on 12 Apr 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2016-2162 and fix it if it is affected.\n\nWhat it is: CVE-2016-2162 is a medium-severity cross-site scripting vulnerability in Apache Struts, published on 12 Apr 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2016-2162 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.struts:struts2-core (Maven): affected from 2.0.0; fixed in 2.3.28\n- org.apache.struts:struts2-core (Maven): affected from 2.0.0; fixed in 2.3.28\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-2162/ (Markdown: https://insights.sbomify.com/CVE-2016-2162/index.md)","id":"CVE-2016-2162","markdown":"https://insights.sbomify.com/CVE-2016-2162/index.md","name":"CVE-2016-2162","record":{"aliases":["GHSA-2j4q-9fff-236j"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Java web framework","requires_auth":"none","summary":"Remote attackers can execute arbitrary scripts in user browsers via unsanitized locale text in Apache Struts, requiring an upgrade to mitigate.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"struts","vendor":"apache"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Apache Struts 2.x before 2.3.25 does not sanitize text in the Locale object constructed by I18NInterceptor, which might allow remote attackers to conduct cross-site scripting (XSS) attacks via unspecified vectors involving language display.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Struts XSS Vulnerability","id":"CVE-2016-2162","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":"apache:struts","products":["apache:struts"],"type":"xss","year":"2016"},"n_packages":2,"n_references":3,"next":{"headline":"Apache OpenMeetings Cross-site Scripting vulnerability","id":"CVE-2016-2163"},"packages":[{"ecosystem":"Maven","fixed":["2.3.28"],"introduced":["2.0.0"],"last_affected":[],"package":"org.apache.struts:struts2-core","purl":null,"source":"GHSA-2j4q-9fff-236j"},{"ecosystem":"Maven","fixed":["2.3.28"],"introduced":["2.0.0"],"last_affected":[],"package":"org.apache.struts:struts2-core","purl":"pkg:maven/org.apache.struts/struts2-core","source":"GHSA-2j4q-9fff-236j"}],"prev":{"headline":"Denial of service in Apache HTTP Server","id":"CVE-2016-2161"},"products":["n/a"],"published":"2016-04-12","related":[{"cvss_score":9.8,"headline":"Apache Struts Remote Code Execution","id":"CVE-2020-17530","kev_date_added":"2021-11-03","published":"2020-12-11"},{"cvss_score":9.8,"headline":"Apache Struts 1 Improper Input Validation","id":"CVE-2017-9791","kev_date_added":"2022-02-10","published":"2017-07-10"},{"cvss_score":9.8,"headline":"Apache Struts Remote Code Execution","id":"CVE-2017-5638","kev_date_added":"2021-11-03","published":"2017-03-11"},{"cvss_score":9.8,"headline":"Apache Struts 2 Improper Input Validation","id":"CVE-2012-0391","kev_date_added":"2022-01-21","published":"2012-01-08"},{"cvss_score":8.1,"headline":"Apache Struts Remote Code Execution","id":"CVE-2018-11776","kev_date_added":"2021-11-03","published":"2018-08-22"},{"cvss_score":8.1,"headline":"Apache Struts Deserialization of Untrusted Data","id":"CVE-2017-9805","kev_date_added":"2021-11-03","published":"2017-09-15"},{"cvss_score":8.1,"headline":"Apache Struts Command Injection","id":"CVE-2016-3081","kev_date_added":"2026-10-08","published":"2016-04-26"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary scripts in user browsers via unsanitized locale text in Apache Struts, requiring an upgrade to mitigate.","url":"https://insights.sbomify.com/CVE-2016-2162/"}