# CVE-2016-2162: Apache Struts XSS Vulnerability

> Remote attackers can execute arbitrary scripts in user browsers via unsanitized locale text in Apache Struts, requiring an upgrade to mitigate.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Apr 2016
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-2j4q-9fff-236j

## What is CVE-2016-2162?

CVE-2016-2162 is a medium-severity cross-site scripting vulnerability in Apache Struts, published on 12 Apr 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Apache Struts 2.x before 2.3.25 does not sanitize text in the Locale object constructed by I18NInterceptor, which might allow remote attackers to conduct cross-site scripting (XSS) attacks via unspecified vectors involving language display.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2016-2162?

2 open source packages ship an affected version, including org.apache.struts:struts2-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.struts:struts2-core` | Maven | From 2.0.0 | 2.3.28 |
| `org.apache.struts:struts2-core` | Maven | From 2.0.0 | 2.3.28 |

Products: Apache Struts.

## How do I fix CVE-2016-2162?

Upgrade org.apache.struts:struts2-core to 2.3.28 or later.

## Is CVE-2016-2162 being exploited?

There is no known exploitation of CVE-2016-2162 in the wild and no public exploit code.

## Other vulnerabilities in Apache Struts

- [CVE-2020-17530](https://insights.sbomify.com/CVE-2020-17530/): Apache Struts Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-9791](https://insights.sbomify.com/CVE-2017-9791/): Apache Struts 1 Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2017-5638](https://insights.sbomify.com/CVE-2017-5638/): Apache Struts Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2012-0391](https://insights.sbomify.com/CVE-2012-0391/): Apache Struts 2 Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2018-11776](https://insights.sbomify.com/CVE-2018-11776/): Apache Struts Remote Code Execution (high 8.1, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-2162 and fix it if it is affected.

What it is: CVE-2016-2162 is a medium-severity cross-site scripting vulnerability in Apache Struts, published on 12 Apr 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2016-2162 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.struts:struts2-core (Maven): affected from 2.0.0; fixed in 2.3.28
- org.apache.struts:struts2-core (Maven): affected from 2.0.0; fixed in 2.3.28

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-2162/ (Markdown: https://insights.sbomify.com/CVE-2016-2162/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-2162
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-2162
- OSV: https://osv.dev/vulnerability/CVE-2016-2162

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-2162/
Summaries are generated and may contain mistakes; the official description above is the record.
