# CVE-2016-2166: Moderate severity vulnerability that affects org.apache.qpid:proton-j

> Man-in-the-middle attackers can intercept or modify data when SSL is unavailable, as the library fails to enforce encryption for amqps URIs.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Apr 2016
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-f5cf-f7px-xpmh, UBUNTU-CVE-2016-2166, openSUSE-SU-2024:10217-1

## What is CVE-2016-2166?

CVE-2016-2166 is a medium-severity vulnerability in Fedoraproject Fedora, published on 12 Apr 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The (1) proton.reactor.Connector, (2) proton.reactor.Container, and (3) proton.utils.BlockingConnection classes in Apache Qpid Proton before 0.12.1 improperly use an unencrypted connection for an amqps URI scheme when SSL support is unavailable, which might allow man-in-the-middle attackers to obtain sensitive information or modify data via unspecified vectors.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2016-2166?

2 open source packages ship an affected version, including org.apache.qpid:proton-j. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.qpid:proton-j` | Maven | All versions | 0.12.1 |
| `org.apache.qpid:proton-j` | Maven | All versions | 0.12.1 |

Products: Apache Qpid Proton, Fedoraproject Fedora.

## How do I fix CVE-2016-2166?

Upgrade org.apache.qpid:proton-j to 0.12.1 or later.

## Is CVE-2016-2166 being exploited?

There is no known exploitation of CVE-2016-2166 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2016-4467](https://insights.sbomify.com/CVE-2016-4467/): Security feature bypass in n/a (medium 5.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-2166 and fix it if it is affected.

What it is: CVE-2016-2166 is a medium-severity vulnerability in Fedoraproject Fedora, published on 12 Apr 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-2166 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.qpid:proton-j (Maven): affected all versions; fixed in 0.12.1
- org.apache.qpid:proton-j (Maven): affected all versions; fixed in 0.12.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-2166/ (Markdown: https://insights.sbomify.com/CVE-2016-2166/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-2166
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-2166
- OSV: https://osv.dev/vulnerability/CVE-2016-2166

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-2166/
Summaries are generated and may contain mistakes; the official description above is the record.
