CVE-2016-2175 High severity vulnerability that affects org.apache.pdfbox:pdfbox

High 7.8 Published Updated

Attackers can exploit XML External Entity vulnerabilities in Apache PDFBox via crafted PDFs to read sensitive data or cause denial of service.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2016-2175?

CVE-2016-2175 is a high-severity vulnerability in Debian Debian Linux, published on 1 Jun 2016. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

Apache PDFBox before 1.8.12 and 2.x before 2.0.1 does not properly initialize the XML parsers, which allows context-dependent attackers to conduct XML External Entity (XXE) attacks via a crafted PDF.

Which versions are affected by CVE-2016-2175?

4 open source packages ship an affected version, including org.apache.pdfbox:pdfbox. It affects 2 products.

PackageAffectedFixed in
org.apache.pdfbox:pdfbox MavenAll versions1.8.12
org.apache.pdfbox:pdfbox MavenAll versions1.8.12
org.apache.pdfbox:pdfbox MavenFrom 2.0.02.0.1
org.apache.pdfbox:pdfbox MavenFrom 2.0.02.0.1

Products include Apache Pdfbox, Debian Debian Linux.

How do I fix CVE-2016-2175?

Upgrade org.apache.pdfbox:pdfbox to a fixed version for your release line: 1.8.12 or 2.0.1.

Is CVE-2016-2175 being exploited?

There is no known exploitation of CVE-2016-2175 in the wild and no public exploit code.

All Debian Debian Linux vulnerabilities

Sources

Also known as DEBIAN-CVE-2016-2175, DLA-505-1, DSA-3606-1, GHSA-4c32-xmgj-2g98, MGASA-2016-0253, UBUNTU-CVE-2016-2175 and 1 more.

Is CVE-2016-2175 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free