{"answers":{"affected":"It affects 4 products.","exploited":"There is no known exploitation of CVE-2016-2347 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2016-2347 is a high-severity vulnerability in Debian Debian Linux, published on 21 Apr 2017. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2016-2347 and fix it if it is affected.\n\nWhat it is: CVE-2016-2347 is a high-severity vulnerability in Debian Debian Linux, published on 21 Apr 2017. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2016-2347 in the wild and no public exploit code.\n\nAffected product: Debian Debian Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-2347/ (Markdown: https://insights.sbomify.com/CVE-2016-2347/index.md)","id":"CVE-2016-2347","markdown":"https://insights.sbomify.com/CVE-2016-2347/index.md","name":"CVE-2016-2347","record":{"aliases":["DEBIAN-CVE-2016-2347","DSA-3540-1","GHSA-9xgv-x5fv-g6vp","SUSE-SU-2016:1091-1","UBUNTU-CVE-2016-2347","openSUSE-SU-2024:10490-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Lhasa archive library","requires_auth":"none","summary":"Remote attackers can execute arbitrary code via a crafted archive due to an integer underflow in the Lhasa library.","user_interaction":"required","vuln_class":"integer_overflow"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"certcc","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"lhasa","vendor":"lhasa_project"},{"product":"leap","vendor":"opensuse"},{"product":"opensuse","vendor":"opensuse"}],"cvss":{"score":7.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-190","name":"Integer Overflow or Wraparound"}],"description":"Integer underflow in the decode_level3_header function in lib/lha_file_header.c in Lhasa before 0.3.1 allows remote attackers to execute arbitrary code via a crafted archive.","ecosystems":["SUSE:Linux Enterprise Desktop 12","SUSE:Linux Enterprise Desktop 12 SP1","SUSE:Linux Enterprise Software Development Kit 12","SUSE:Linux Enterprise Software Development Kit 12 SP1","SUSE:Linux Enterprise Workstation Extension 12","SUSE:Linux Enterprise Workstation Extension 12 SP1"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Integer overflow in n/a","id":"CVE-2016-2347","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"debian:debian_linux","products":["debian:debian_linux","opensuse:leap","opensuse:opensuse"],"type":"integer_overflow","year":"2016"},"n_packages":6,"n_references":6,"next":{"headline":"Auth bypass in n/a","id":"CVE-2016-2349"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Desktop 12","fixed":["0.2.0-5.1"],"introduced":["0"],"last_affected":[],"package":"lhasa","purl":"pkg:rpm/suse/lhasa\u0026distro=SUSE%20Linux%20Enterprise%20Desktop%2012","source":"SUSE-SU-2016:1091-1"},{"ecosystem":"SUSE:Linux Enterprise Desktop 12 SP1","fixed":["0.2.0-5.1"],"introduced":["0"],"last_affected":[],"package":"lhasa","purl":"pkg:rpm/suse/lhasa\u0026distro=SUSE%20Linux%20Enterprise%20Desktop%2012%20SP1","source":"SUSE-SU-2016:1091-1"},{"ecosystem":"SUSE:Linux Enterprise Software Development Kit 12","fixed":["0.2.0-5.1"],"introduced":["0"],"last_affected":[],"package":"lhasa","purl":"pkg:rpm/suse/lhasa\u0026distro=SUSE%20Linux%20Enterprise%20Software%20Development%20Kit%2012","source":"SUSE-SU-2016:1091-1"},{"ecosystem":"SUSE:Linux Enterprise Software Development Kit 12 SP1","fixed":["0.2.0-5.1"],"introduced":["0"],"last_affected":[],"package":"lhasa","purl":"pkg:rpm/suse/lhasa\u0026distro=SUSE%20Linux%20Enterprise%20Software%20Development%20Kit%2012%20SP1","source":"SUSE-SU-2016:1091-1"},{"ecosystem":"SUSE:Linux Enterprise Workstation Extension 12","fixed":["0.2.0-5.1"],"introduced":["0"],"last_affected":[],"package":"lhasa","purl":"pkg:rpm/suse/lhasa\u0026distro=SUSE%20Linux%20Enterprise%20Workstation%20Extension%2012","source":"SUSE-SU-2016:1091-1"},{"ecosystem":"SUSE:Linux Enterprise Workstation Extension 12 SP1","fixed":["0.2.0-5.1"],"introduced":["0"],"last_affected":[],"package":"lhasa","purl":"pkg:rpm/suse/lhasa\u0026distro=SUSE%20Linux%20Enterprise%20Workstation%20Extension%2012%20SP1","source":"SUSE-SU-2016:1091-1"}],"prev":{"headline":"Supply chain in n/a","id":"CVE-2016-2346"},"products":["n/a"],"published":"2017-04-21","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary code via a crafted archive due to an integer underflow in the Lhasa library.","url":"https://insights.sbomify.com/CVE-2016-2347/"}