CVE-2016-2512 Django XSS Vulnerability
Remote attackers can redirect users to arbitrary sites or conduct phishing/XSS attacks via URLs with basic authentication in Django.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2016-2512?
CVE-2016-2512 is a high-severity vulnerability in Djangoproject Django, published on 8 Apr 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
The utils.http.is_safe_url function in Django before 1.8.10 and 1.9.x before 1.9.3 allows remote attackers to redirect users to arbitrary web sites and conduct phishing attacks or possibly conduct cross-site scripting (XSS) attacks via a URL containing basic authentication, as demonstrated by http://mysite.example.com\@attacker.com.
Weakness: CWE-79
Which versions are affected by CVE-2016-2512?
5 open source packages ship an affected version, including django and Django. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
django PyPI | All versions | 1.8.10, 1.9.3 |
django PyPI | All versions | 1.8.10 |
django PyPI | From 1.9a1 | 1.9.3 |
Django PyPI | All versions | 1.8.10 |
Django PyPI | From 1.9a1 | 1.9.3 |
Products include Djangoproject Django.
How do I fix CVE-2016-2512?
Upgrade django to a fixed version for your release line: 1.8.10 or 1.9.3.
Is CVE-2016-2512 being exploited?
There is no known exploitation of CVE-2016-2512 in the wild and no public exploit code.
Other vulnerabilities in Djangoproject Django
- CVE-2026-4277 Privilege abuse in GenericInlineModelAdmin
- CVE-2024-53908 Django SQL injection in HasKey(lhs, rhs) on Oracle
- CVE-2024-42005 Django SQL injection vulnerability
- CVE-2023-31047 Django bypasses validation when using one form field to upload multiple files
- CVE-2022-34265 Django `Trunc()` and `Extract()` database functions vulnerable to SQL Injection
Sources
Also known as DEBIAN-CVE-2016-2512, GHSA-pw27-w7w4-9qc7, PYSEC-2016-15, UBUNTU-CVE-2016-2512.