CVE-2016-2513 Django User Enumeration Vulnerability

Low 3.1 Published Updated

Remote attackers can enumerate valid users via timing attacks on login requests in the Django password hasher.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2016-2513?

CVE-2016-2513 is a low-severity vulnerability in Djangoproject Django, published on 8 Apr 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

The password hasher in contrib/auth/hashers.py in Django before 1.8.10 and 1.9.x before 1.9.3 allows remote attackers to enumerate users via a timing attack involving login requests.

Weakness: CWE-200

Which versions are affected by CVE-2016-2513?

5 open source packages ship an affected version, including django and Django. It affects 1 product.

PackageAffectedFixed in
django PyPIAll versions1.8.10, 1.9.3
django PyPIAll versions1.8.10
django PyPIFrom 1.91.9.3
Django PyPIAll versions1.8.10
Django PyPIFrom 1.91.9.3

Products include Djangoproject Django.

How do I fix CVE-2016-2513?

Upgrade django to a fixed version for your release line: 1.8.10 or 1.9.3.

Is CVE-2016-2513 being exploited?

There is no known exploitation of CVE-2016-2513 in the wild and no public exploit code.

All Djangoproject Django vulnerabilities

Sources

Also known as DEBIAN-CVE-2016-2513, GHSA-fp6p-5xvw-m74f, PYSEC-2016-16, UBUNTU-CVE-2016-2513.

Is CVE-2016-2513 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free