{"answers":{"affected":"4 open source packages ship an affected version, including hawk. It affects 1 product.","exploited":"There is no known exploitation of CVE-2016-2515 in the wild and no public exploit code.","fix":"Upgrade hawk to a fixed version for your release line: 3.1.3 or 4.1.1.","what":"CVE-2016-2515 is a high-severity denial of service vulnerability in n/a, published on 13 Apr 2016. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-2515 and fix it if it is affected.\n\nWhat it is: CVE-2016-2515 is a high-severity denial of service vulnerability in n/a, published on 13 Apr 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2016-2515 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- hawk (npm): affected all versions; fixed in 3.1.3\n- hawk (npm): affected all versions; fixed in 3.1.3\n- hawk (npm): affected from 4.0.0; fixed in 4.1.1\n- hawk (npm): affected from 4.0.0; fixed in 4.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-2515/ (Markdown: https://insights.sbomify.com/CVE-2016-2515/index.md)","id":"CVE-2016-2515","markdown":"https://insights.sbomify.com/CVE-2016-2515/index.md","name":"CVE-2016-2515","record":{"aliases":["GHSA-jcpv-g9rr-qxrc"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js Hawk library","requires_auth":"none","summary":"Remote attackers can cause denial of service via CPU exhaustion using long headers or URIs in the Hawk library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"hawk","vendor":"hawk_project"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-399","name":null}],"description":"Hawk before 3.1.3 and 4.x before 4.1.1 allow remote attackers to cause a denial of service (CPU consumption or partial outage) via a long (1) header or (2) URI that is matched against an improper regular expression.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Regular Expression Denial of Service in hawk","id":"CVE-2016-2515","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2016"},"n_packages":4,"n_references":6,"next":{"headline":"Denial of service in n/a","id":"CVE-2016-2516"},"packages":[{"ecosystem":"npm","fixed":["3.1.3"],"introduced":["0"],"last_affected":[],"package":"hawk","purl":null,"source":"GHSA-jcpv-g9rr-qxrc"},{"ecosystem":"npm","fixed":["3.1.3"],"introduced":["0"],"last_affected":[],"package":"hawk","purl":"pkg:npm/hawk","source":"GHSA-jcpv-g9rr-qxrc"},{"ecosystem":"npm","fixed":["4.1.1"],"introduced":["4.0.0"],"last_affected":[],"package":"hawk","purl":null,"source":"GHSA-jcpv-g9rr-qxrc"},{"ecosystem":"npm","fixed":["4.1.1"],"introduced":["4.0.0"],"last_affected":[],"package":"hawk","purl":"pkg:npm/hawk","source":"GHSA-jcpv-g9rr-qxrc"}],"prev":{"headline":"Django User Enumeration Vulnerability","id":"CVE-2016-2513"},"products":["n/a"],"published":"2016-04-13","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Remote attackers can cause denial of service via CPU exhaustion using long headers or URIs in the Hawk library.","url":"https://insights.sbomify.com/CVE-2016-2515/"}