# CVE-2016-2515: Regular Expression Denial of Service in hawk

> Remote attackers can cause denial of service via CPU exhaustion using long headers or URIs in the Hawk library.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Apr 2016
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-jcpv-g9rr-qxrc

## What is CVE-2016-2515?

CVE-2016-2515 is a high-severity denial of service vulnerability in n/a, published on 13 Apr 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Hawk before 3.1.3 and 4.x before 4.1.1 allow remote attackers to cause a denial of service (CPU consumption or partial outage) via a long (1) header or (2) URI that is matched against an improper regular expression.

Weakness: CWE-399

## Which versions are affected by CVE-2016-2515?

4 open source packages ship an affected version, including hawk. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `hawk` | npm | All versions | 3.1.3 |
| `hawk` | npm | All versions | 3.1.3 |
| `hawk` | npm | From 4.0.0 | 4.1.1 |
| `hawk` | npm | From 4.0.0 | 4.1.1 |

Products: Hawk Project Hawk.

## How do I fix CVE-2016-2515?

Upgrade hawk to a fixed version for your release line: 3.1.3 or 4.1.1.

## Is CVE-2016-2515 being exploited?

There is no known exploitation of CVE-2016-2515 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-2515 and fix it if it is affected.

What it is: CVE-2016-2515 is a high-severity denial of service vulnerability in n/a, published on 13 Apr 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-2515 in the wild and no public exploit code.

Affected packages and fixed versions:
- hawk (npm): affected all versions; fixed in 3.1.3
- hawk (npm): affected all versions; fixed in 3.1.3
- hawk (npm): affected from 4.0.0; fixed in 4.1.1
- hawk (npm): affected from 4.0.0; fixed in 4.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-2515/ (Markdown: https://insights.sbomify.com/CVE-2016-2515/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-2515
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-2515
- OSV: https://osv.dev/vulnerability/CVE-2016-2515

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-2515/
Summaries are generated and may contain mistakes; the official description above is the record.
