{"answers":{"affected":"2 open source packages ship an affected version, including is-my-json-valid. It affects 1 product.","exploited":"There is no known exploitation of CVE-2016-2537 in the wild and no public exploit code.","fix":"Upgrade is-my-json-valid to 2.12.4 or later.","what":"CVE-2016-2537 is a high-severity denial of service vulnerability in n/a, published on 23 Feb 2016. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-2537 and fix it if it is affected.\n\nWhat it is: CVE-2016-2537 is a high-severity denial of service vulnerability in n/a, published on 23 Feb 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2016-2537 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- is-my-json-valid (npm): affected all versions; fixed in 2.12.4\n- is-my-json-valid (npm): affected all versions; fixed in 2.12.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-2537/ (Markdown: https://insights.sbomify.com/CVE-2016-2537/index.md)","id":"CVE-2016-2537","markdown":"https://insights.sbomify.com/CVE-2016-2537/index.md","name":"CVE-2016-2537","record":{"aliases":["GHSA-f522-ffg8-j8r6"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js JSON validation library","requires_auth":"none","summary":"Remote attackers can cause a denial of service by sending crafted strings that block the event loop in the is-my-json-valid Node.js package.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"is_my_json_valid","vendor":"is_my_json_valid_project"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"The is-my-json-valid package before 2.12.4 for Node.js has an incorrect exports['utc-millisec'] regular expression, which allows remote attackers to cause a denial of service (blocked event loop) via a crafted string.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Regular Expression Denial of Service in is-my-json-valid","id":"CVE-2016-2537","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2016"},"n_packages":2,"n_references":2,"next":{"headline":"Integer overflow in n/a","id":"CVE-2016-2538"},"packages":[{"ecosystem":"npm","fixed":["2.12.4"],"introduced":["0"],"last_affected":[],"package":"is-my-json-valid","purl":null,"source":"GHSA-f522-ffg8-j8r6"},{"ecosystem":"npm","fixed":["2.12.4"],"introduced":["0"],"last_affected":[],"package":"is-my-json-valid","purl":"pkg:npm/is-my-json-valid","source":"GHSA-f522-ffg8-j8r6"}],"prev":{"headline":"Use after free in n/a","id":"CVE-2016-2536"},"products":["n/a"],"published":"2016-02-23","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Remote attackers can cause a denial of service by sending crafted strings that block the event loop in the is-my-json-valid Node.js package.","url":"https://insights.sbomify.com/CVE-2016-2537/"}