# CVE-2016-2537: Regular Expression Denial of Service in is-my-json-valid

> Remote attackers can cause a denial of service by sending crafted strings that block the event loop in the is-my-json-valid Node.js package.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Feb 2016
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-f522-ffg8-j8r6

## What is CVE-2016-2537?

CVE-2016-2537 is a high-severity denial of service vulnerability in n/a, published on 23 Feb 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The is-my-json-valid package before 2.12.4 for Node.js has an incorrect exports['utc-millisec'] regular expression, which allows remote attackers to cause a denial of service (blocked event loop) via a crafted string.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2016-2537?

2 open source packages ship an affected version, including is-my-json-valid. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `is-my-json-valid` | npm | All versions | 2.12.4 |
| `is-my-json-valid` | npm | All versions | 2.12.4 |

Products: Is My Json Valid Project Is My Json Valid.

## How do I fix CVE-2016-2537?

Upgrade is-my-json-valid to 2.12.4 or later.

## Is CVE-2016-2537 being exploited?

There is no known exploitation of CVE-2016-2537 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-2537 and fix it if it is affected.

What it is: CVE-2016-2537 is a high-severity denial of service vulnerability in n/a, published on 23 Feb 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-2537 in the wild and no public exploit code.

Affected packages and fixed versions:
- is-my-json-valid (npm): affected all versions; fixed in 2.12.4
- is-my-json-valid (npm): affected all versions; fixed in 2.12.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-2537/ (Markdown: https://insights.sbomify.com/CVE-2016-2537/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-2537
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-2537
- OSV: https://osv.dev/vulnerability/CVE-2016-2537

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-2537/
Summaries are generated and may contain mistakes; the official description above is the record.
