# CVE-2016-2559: phpMyAdmin Cross-site scripting (XSS) vulnerability in SQL parser

> Authenticated attackers can inject arbitrary web script or HTML via crafted queries in phpMyAdmin's SQL parser, potentially leading to session hijacking or malicious actions.

- **Severity:** Medium 5.4 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 1 Mar 2016
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2016-2559, GHSA-7rf8-9r8f-qf59, UBUNTU-CVE-2016-2559

## What is CVE-2016-2559?

CVE-2016-2559 is a medium-severity cross-site scripting vulnerability in Phpmyadmin Phpmyadmin, published on 1 Mar 2016. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Cross-site scripting (XSS) vulnerability in the format function in libraries/sql-parser/src/Utils/Error.php in the SQL parser in phpMyAdmin 4.5.x before 4.5.5.1 allows remote authenticated users to inject arbitrary web script or HTML via a crafted query.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2016-2559?

2 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.5 | 4.5.5.1 |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.5 | 4.5.5.1 |

Products: Phpmyadmin Phpmyadmin.

## How do I fix CVE-2016-2559?

Upgrade phpmyadmin/phpmyadmin to 4.5.5.1 or later.

## Is CVE-2016-2559 being exploited?

There is no known exploitation of CVE-2016-2559 in the wild and no public exploit code.

## Other vulnerabilities in Phpmyadmin Phpmyadmin

- [CVE-2008-7251](https://insights.sbomify.com/CVE-2008-7251/): Misconfiguration in n/a (critical 10.0)
- [CVE-2008-7252](https://insights.sbomify.com/CVE-2008-7252/): phpMyAdmin unsafely handles temporary files (critical 10.0)
- [CVE-2007-0203](https://insights.sbomify.com/CVE-2007-0203/): Other in n/a (critical 10.0)
- [CVE-2004-1147](https://insights.sbomify.com/CVE-2004-1147/): Command injection in n/a (critical 10.0)
- [CVE-2020-22452](https://insights.sbomify.com/CVE-2020-22452/): phpmyadmin contains SQL Injection vulnerability (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-2559 and fix it if it is affected.

What it is: CVE-2016-2559 is a medium-severity cross-site scripting vulnerability in Phpmyadmin Phpmyadmin, published on 1 Mar 2016. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2016-2559 in the wild and no public exploit code.

Affected packages and fixed versions:
- phpmyadmin/phpmyadmin (Packagist): affected from 4.5; fixed in 4.5.5.1
- phpmyadmin/phpmyadmin (Packagist): affected from 4.5; fixed in 4.5.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-2559/ (Markdown: https://insights.sbomify.com/CVE-2016-2559/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-2559
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-2559
- OSV: https://osv.dev/vulnerability/CVE-2016-2559

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-2559/
Summaries are generated and may contain mistakes; the official description above is the record.
