{"answers":{"affected":"2 open source packages ship an affected version, including puppet. It affects 3 products.","exploited":"There is no known exploitation of CVE-2016-2785 in the wild and no public exploit code.","fix":"Upgrade puppet to 4.4.2 or later.","what":"CVE-2016-2785 is a critical authentication bypass vulnerability in n/a, published on 10 Jun 2016. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-2785 and fix it if it is affected.\n\nWhat it is: CVE-2016-2785 is a critical authentication bypass vulnerability in n/a, published on 10 Jun 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2016-2785 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- puppet (RubyGems): affected from 4.0.0; fixed in 4.4.2\n- puppet (RubyGems): affected from 4.0.0; fixed in 4.4.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-2785/ (Markdown: https://insights.sbomify.com/CVE-2016-2785/index.md)","id":"CVE-2016-2785","markdown":"https://insights.sbomify.com/CVE-2016-2785/index.md","name":"CVE-2016-2785","record":{"aliases":["GHSA-pqj5-7r86-64fv"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Puppet Server","requires_auth":"none","summary":"Remote attackers can bypass authentication restrictions in Puppet Server due to incorrect URL decoding, potentially accessing unauthorized resources.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"puppet","vendor":"puppet"},{"product":"puppet_agent","vendor":"puppet"},{"product":"puppet_server","vendor":"puppet"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-284","name":"Improper Access Control"}],"description":"Puppet Server before 2.3.2 and Ruby puppetmaster in Puppet 4.x before 4.4.2 and in Puppet Agent before 1.4.2 might allow remote attackers to bypass intended auth.conf access restrictions by leveraging incorrect URL decoding.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Puppet Improper Access Control","id":"CVE-2016-2785","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"auth_bypass","year":"2016"},"n_packages":2,"n_references":3,"next":{"headline":"Security feature bypass in n/a","id":"CVE-2016-2786"},"packages":[{"ecosystem":"RubyGems","fixed":["4.4.2"],"introduced":["4.0.0"],"last_affected":[],"package":"puppet","purl":null,"source":"GHSA-pqj5-7r86-64fv"},{"ecosystem":"RubyGems","fixed":["4.4.2"],"introduced":["4.0.0"],"last_affected":[],"package":"puppet","purl":"pkg:gem/puppet","source":"GHSA-pqj5-7r86-64fv"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2016-2784"},"products":["n/a"],"published":"2016-06-10","related":[{"cvss_score":8.8,"headline":"SQL injection in Puppet DB","id":"CVE-2021-27021","kev_date_added":null,"published":"2021-07-20"},{"cvss_score":8.8,"headline":"Privilege escalation in Puppet Enterprise and Puppet Agent","id":"CVE-2018-6513","kev_date_added":null,"published":"2018-06-11"},{"cvss_score":7.8,"headline":"Privilege escalation in Puppet Agent","id":"CVE-2018-6514","kev_date_added":null,"published":"2018-06-11"},{"cvss_score":7.8,"headline":"Code injection in Puppet Agent","id":"CVE-2018-6515","kev_date_added":null,"published":"2018-06-11"},{"cvss_score":7.5,"headline":"Puppet Improper Input Validation vulnerability","id":"CVE-2013-1655","kev_date_added":null,"published":"2013-03-20"},{"cvss_score":6.9,"headline":"Puppet Privilege Escallation","id":"CVE-2012-1053","kev_date_added":null,"published":"2012-05-29"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Remote attackers can bypass authentication restrictions in Puppet Server due to incorrect URL decoding, potentially accessing unauthorized resources.","url":"https://insights.sbomify.com/CVE-2016-2785/"}