# CVE-2016-2785: Puppet Improper Access Control

> Remote attackers can bypass authentication restrictions in Puppet Server due to incorrect URL decoding, potentially accessing unauthorized resources.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jun 2016
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-pqj5-7r86-64fv

## What is CVE-2016-2785?

CVE-2016-2785 is a critical authentication bypass vulnerability in n/a, published on 10 Jun 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Puppet Server before 2.3.2 and Ruby puppetmaster in Puppet 4.x before 4.4.2 and in Puppet Agent before 1.4.2 might allow remote attackers to bypass intended auth.conf access restrictions by leveraging incorrect URL decoding.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2016-2785?

2 open source packages ship an affected version, including puppet. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `puppet` | RubyGems | From 4.0.0 | 4.4.2 |
| `puppet` | RubyGems | From 4.0.0 | 4.4.2 |

Products: Puppet Puppet, Puppet Puppet Agent, Puppet Puppet Server.

## How do I fix CVE-2016-2785?

Upgrade puppet to 4.4.2 or later.

## Is CVE-2016-2785 being exploited?

There is no known exploitation of CVE-2016-2785 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-27021](https://insights.sbomify.com/CVE-2021-27021/): SQL injection in Puppet DB (high 8.8)
- [CVE-2018-6513](https://insights.sbomify.com/CVE-2018-6513/): Privilege escalation in Puppet Enterprise and Puppet Agent (high 8.8)
- [CVE-2018-6514](https://insights.sbomify.com/CVE-2018-6514/): Privilege escalation in Puppet Agent (high 7.8)
- [CVE-2018-6515](https://insights.sbomify.com/CVE-2018-6515/): Code injection in Puppet Agent (high 7.8)
- [CVE-2013-1655](https://insights.sbomify.com/CVE-2013-1655/): Puppet Improper Input Validation vulnerability (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-2785 and fix it if it is affected.

What it is: CVE-2016-2785 is a critical authentication bypass vulnerability in n/a, published on 10 Jun 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-2785 in the wild and no public exploit code.

Affected packages and fixed versions:
- puppet (RubyGems): affected from 4.0.0; fixed in 4.4.2
- puppet (RubyGems): affected from 4.0.0; fixed in 4.4.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-2785/ (Markdown: https://insights.sbomify.com/CVE-2016-2785/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-2785
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-2785
- OSV: https://osv.dev/vulnerability/CVE-2016-2785

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-2785/
Summaries are generated and may contain mistakes; the official description above is the record.
