# CVE-2016-3068: Mercurial arbitrary code execution via a crafted git ext:: URL

> Remote attackers can execute arbitrary code by tricking users into cloning a subrepository with a crafted git ext:: URL.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 Apr 2016
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2016-3068, GHSA-j7c2-rqm3-c97m, PYSEC-2016-26, UBUNTU-CVE-2016-3068

## What is CVE-2016-3068?

CVE-2016-3068 is a high-severity command injection vulnerability in Debian Debian Linux, published on 13 Apr 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Mercurial before 3.7.3 allows remote attackers to execute arbitrary code via a crafted git ext:: URL when cloning a subrepository.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2016-3068?

3 open source packages ship an affected version, including mercurial. It affects 14 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mercurial` | PyPI | All versions | 3.7.3 |
| `mercurial` | PyPI | All versions | 3.7.3 |
| `mercurial` | PyPI | All versions | 3.7.3 |

Products: Debian Debian Linux, Fedoraproject Fedora, Mercurial Mercurial, Opensuse Leap, Opensuse Opensuse, Redhat Enterprise Linux Desktop, Redhat Enterprise Linux Hpc Node, Redhat Enterprise Linux Hpc Node Eus, Redhat Enterprise Linux Server, Redhat Enterprise Linux Server Aus, Redhat Enterprise Linux Server Eus, Redhat Enterprise Linux Workstation, Suse Linux Enterprise Debuginfo, Suse Linux Enterprise Software Development Kit.

## How do I fix CVE-2016-3068?

Upgrade mercurial to 3.7.3 or later.

## Is CVE-2016-3068 being exploited?

There is no known exploitation of CVE-2016-3068 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-3068 and fix it if it is affected.

What it is: CVE-2016-3068 is a high-severity command injection vulnerability in Debian Debian Linux, published on 13 Apr 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2016-3068 in the wild and no public exploit code.

Affected packages and fixed versions:
- mercurial (PyPI): affected all versions; fixed in 3.7.3
- mercurial (PyPI): affected all versions; fixed in 3.7.3
- mercurial (PyPI): affected all versions; fixed in 3.7.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-3068/ (Markdown: https://insights.sbomify.com/CVE-2016-3068/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-3068
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-3068
- OSV: https://osv.dev/vulnerability/CVE-2016-3068

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-3068/
Summaries are generated and may contain mistakes; the official description above is the record.
