{"answers":{"affected":"2 open source packages ship an affected version, including katello. It affects 2 products.","exploited":"There is no known exploitation of CVE-2016-3072 in the wild and no public exploit code.","fix":"Upgrade katello to 2.4.3 or later.","what":"CVE-2016-3072 is a high-severity SQL injection vulnerability in Redhat Satellite, published on 7 Jun 2016. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-3072 and fix it if it is affected.\n\nWhat it is: CVE-2016-3072 is a high-severity SQL injection vulnerability in Redhat Satellite, published on 7 Jun 2016. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2016-3072 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- katello (RubyGems): affected all versions; fixed in 2.4.3\n- katello (RubyGems): affected all versions; fixed in 2.4.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-3072/ (Markdown: https://insights.sbomify.com/CVE-2016-3072/index.md)","id":"CVE-2016-3072","markdown":"https://insights.sbomify.com/CVE-2016-3072/index.md","name":"CVE-2016-3072","record":{"aliases":["GHSA-527r-mfmj-prqf","RHSA-2016:1083"],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Katello management tool","requires_auth":"low_privilege","summary":"Authenticated users can execute arbitrary SQL commands via sort parameters in Katello, potentially compromising database integrity and confidentiality.","user_interaction":"not_required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"katello","vendor":"katello"},{"product":"satellite","vendor":"redhat"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"}],"description":"Multiple SQL injection vulnerabilities in the scoped_search function in app/controllers/katello/api/v2/api_controller.rb in Katello allow remote authenticated users to execute arbitrary SQL commands via the (1) sort_by or (2) sort_order parameter.","ecosystems":["Red Hat:satellite:6.1::el6","Red Hat:satellite:6.1::el7","RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Katello SQL Injection vulnerabilities","id":"CVE-2016-3072","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":"redhat:satellite","products":["redhat:satellite"],"type":"sql_injection","year":"2016"},"n_packages":4,"n_references":3,"next":{"headline":"Integer overflow in n/a","id":"CVE-2016-3074"},"packages":[{"ecosystem":"RubyGems","fixed":["2.4.3"],"introduced":["0"],"last_affected":[],"package":"katello","purl":null,"source":"GHSA-527r-mfmj-prqf"},{"ecosystem":"RubyGems","fixed":["2.4.3"],"introduced":["0"],"last_affected":[],"package":"katello","purl":"pkg:gem/katello","source":"GHSA-527r-mfmj-prqf"},{"ecosystem":"Red Hat:satellite:6.1::el6","fixed":["0:2.2.0.86-1.el6_6sat"],"introduced":["0"],"last_affected":[],"package":"ruby193-rubygem-katello","purl":"pkg:rpm/redhat/ruby193-rubygem-katello","source":"RHSA-2016:1083"},{"ecosystem":"Red Hat:satellite:6.1::el7","fixed":["0:2.2.0.86-1.el7sat"],"introduced":["0"],"last_affected":[],"package":"ruby193-rubygem-katello","purl":"pkg:rpm/redhat/ruby193-rubygem-katello","source":"RHSA-2016:1083"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2016-3071"},"products":["n/a"],"published":"2016-06-07","related":[{"cvss_score":5,"headline":"Denial of service in n/a","id":"CVE-2014-3712","kev_date_added":null,"published":"2014-11-03"},{"cvss_score":4.3,"headline":"Missing authorization in n/a","id":"CVE-2013-4201","kev_date_added":null,"published":"2018-05-01"},{"cvss_score":2.1,"headline":"Information disclosure in n/a","id":"CVE-2012-5561","kev_date_added":null,"published":"2013-03-01"},{"cvss_score":2.1,"headline":"Misconfiguration in n/a","id":"CVE-2012-6116","kev_date_added":null,"published":"2013-03-01"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Red Hat","prefix":"RHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Authenticated users can execute arbitrary SQL commands via sort parameters in Katello, potentially compromising database integrity and confidentiality.","url":"https://insights.sbomify.com/CVE-2016-3072/"}