CVE-2016-3082 Remote Code Execution in Apache Struts
Remote attackers can execute arbitrary code via the stylesheet location parameter in Apache Struts XSLTResult.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2016-3082?
CVE-2016-3082 is a critical code injection vulnerability in Apache Struts, published on 26 Apr 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
XSLTResult in Apache Struts 2.x before 2.3.20.2, 2.3.24.x before 2.3.24.2, and 2.3.28.x before 2.3.28.1 allows remote attackers to execute arbitrary code via the stylesheet location parameter.
Weakness: CWE-20
Which versions are affected by CVE-2016-3082?
6 open source packages ship an affected version, including org.apache.struts:struts2-core. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.struts:struts2-core Maven | All versions | 2.3.20.3 |
org.apache.struts:struts2-core Maven | All versions | 2.3.20.3 |
org.apache.struts:struts2-core Maven | From 2.3.24 | 2.3.24.3 |
org.apache.struts:struts2-core Maven | From 2.3.24 | 2.3.24.3 |
org.apache.struts:struts2-core Maven | From 2.3.28 | 2.3.28.1 |
org.apache.struts:struts2-core Maven | From 2.3.28 | 2.3.28.1 |
Products include Apache Struts.
How do I fix CVE-2016-3082?
Upgrade org.apache.struts:struts2-core to a fixed version for your release line: 2.3.20.3, 2.3.24.3 or 2.3.28.1.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2016-3082 being exploited?
There is no known exploitation of CVE-2016-3082 in the wild and no public exploit code.
Other vulnerabilities in Apache Struts
Sources
Also known as GHSA-pvm9-288c-v5wq.