CVE-2016-3083 org.apache.hive:hive, org.apache.hive:hive-exec, and org.apache.hive:hive-service vulnerable to Improper Certificate Validation
Apache Hive JDBC clients fail to verify certificate common names, allowing man-in-the-middle attacks when SSL is enabled.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2016-3083?
CVE-2016-3083 is a high-severity vulnerability in Apache Hive, published on 30 May 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Apache Hive (JDBC + HiveServer2) implements SSL for plain TCP and HTTP connections (it supports both transport modes). While validating the server's certificate during the connection setup, the client in Apache Hive before 1.2.2 and 2.0.x before 2.0.1 doesn't seem to be verifying the common name attribute of the certificate. In this way, if a JDBC client sends an SSL request to server abc.com, and the server responds with a valid certificate (certified by CA) but issued to xyz.com, the client will accept that as a valid certificate and the SSL handshake will go through.
Weakness: CWE-295
Which versions are affected by CVE-2016-3083?
12 open source packages ship an affected version, including org.apache.hive:hive, org.apache.hive:hive-exec and org.apache.hive:hive-service. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.hive:hive Maven | All versions | 1.2.2 |
org.apache.hive:hive Maven | All versions | 1.2.2 |
org.apache.hive:hive Maven | From 2.0.0 | 2.0.1 |
org.apache.hive:hive Maven | From 2.0.0 | 2.0.1 |
org.apache.hive:hive-exec Maven | All versions | 1.2.2 |
org.apache.hive:hive-exec Maven | All versions | 1.2.2 |
6 more packages
org.apache.hive:hive-exec Maven | From 2.0.0 | 2.0.1 |
org.apache.hive:hive-exec Maven | From 2.0.0 | 2.0.1 |
org.apache.hive:hive-service Maven | All versions | 1.2.2 |
org.apache.hive:hive-service Maven | All versions | 1.2.2 |
org.apache.hive:hive-service Maven | From 2.0.0 | 2.0.1 |
org.apache.hive:hive-service Maven | From 2.0.0 | 2.0.1 |
Products include Apache Hive.
How do I fix CVE-2016-3083?
Upgrade org.apache.hive:hive to a fixed version for your release line: 1.2.2 or 2.0.1.
Is CVE-2016-3083 being exploited?
There is no known exploitation of CVE-2016-3083 in the wild and no public exploit code.
Other vulnerabilities in Apache Hive
- CVE-2026-49845 Apache Hive: SQL Injection vulnerability in HiveMetaStore partition-name direct-SQL paths
- CVE-2018-21234 Deserialization of Untrusted Data in Jodd
- CVE-2026-55976 Apache Hive: SSRF vulnerability in Hive Avro Serde due to Insufficient input validation on avro.schema.url
- CVE-2018-1282 SQL Injection in hive-jdbc
- CVE-2022-41137 Apache Hive: Deserialization of untrusted data when fetching partitions from the Metastore
Sources
Also known as GHSA-gf2v-9hp6-44qg.