# CVE-2016-3083: org.apache.hive:hive, org.apache.hive:hive-exec, and org.apache.hive:hive-service vulnerable to Improper Certificate Validation

> Apache Hive JDBC clients fail to verify certificate common names, allowing man-in-the-middle attacks when SSL is enabled.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 May 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-gf2v-9hp6-44qg

## What is CVE-2016-3083?

CVE-2016-3083 is a high-severity vulnerability in Apache Hive, published on 30 May 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache Hive (JDBC + HiveServer2) implements SSL for plain TCP and HTTP connections (it supports both transport modes). While validating the server's certificate during the connection setup, the client in Apache Hive before 1.2.2 and 2.0.x before 2.0.1 doesn't seem to be verifying the common name attribute of the certificate. In this way, if a JDBC client sends an SSL request to server abc.com, and the server responds with a valid certificate (certified by CA) but issued to xyz.com, the client will accept that as a valid certificate and the SSL handshake will go through.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2016-3083?

12 open source packages ship an affected version, including org.apache.hive:hive, org.apache.hive:hive-exec and org.apache.hive:hive-service. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.hive:hive` | Maven | All versions | 1.2.2 |
| `org.apache.hive:hive` | Maven | All versions | 1.2.2 |
| `org.apache.hive:hive` | Maven | From 2.0.0 | 2.0.1 |
| `org.apache.hive:hive` | Maven | From 2.0.0 | 2.0.1 |
| `org.apache.hive:hive-exec` | Maven | All versions | 1.2.2 |
| `org.apache.hive:hive-exec` | Maven | All versions | 1.2.2 |
| `org.apache.hive:hive-exec` | Maven | From 2.0.0 | 2.0.1 |
| `org.apache.hive:hive-exec` | Maven | From 2.0.0 | 2.0.1 |
| `org.apache.hive:hive-service` | Maven | All versions | 1.2.2 |
| `org.apache.hive:hive-service` | Maven | All versions | 1.2.2 |
| `org.apache.hive:hive-service` | Maven | From 2.0.0 | 2.0.1 |
| `org.apache.hive:hive-service` | Maven | From 2.0.0 | 2.0.1 |

Products: Apache Hive.

## How do I fix CVE-2016-3083?

Upgrade org.apache.hive:hive to a fixed version for your release line: 1.2.2 or 2.0.1.

## Is CVE-2016-3083 being exploited?

There is no known exploitation of CVE-2016-3083 in the wild and no public exploit code.

## Other vulnerabilities in Apache Hive

- [CVE-2026-49845](https://insights.sbomify.com/CVE-2026-49845/): Apache Hive: SQL Injection vulnerability in HiveMetaStore partition-name direct-SQL paths (critical 9.8)
- [CVE-2018-21234](https://insights.sbomify.com/CVE-2018-21234/): Deserialization of Untrusted Data in Jodd (critical 9.8)
- [CVE-2026-55976](https://insights.sbomify.com/CVE-2026-55976/): Apache Hive: SSRF vulnerability in Hive Avro Serde due to Insufficient input validation on avro.schema.url (critical 9.1)
- [CVE-2018-1282](https://insights.sbomify.com/CVE-2018-1282/): SQL Injection in hive-jdbc (critical 9.1)
- [CVE-2022-41137](https://insights.sbomify.com/CVE-2022-41137/): Apache Hive: Deserialization of untrusted data when fetching partitions from the Metastore (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-3083 and fix it if it is affected.

What it is: CVE-2016-3083 is a high-severity vulnerability in Apache Hive, published on 30 May 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-3083 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.hive:hive (Maven): affected all versions; fixed in 1.2.2
- org.apache.hive:hive (Maven): affected all versions; fixed in 1.2.2
- org.apache.hive:hive (Maven): affected from 2.0.0; fixed in 2.0.1
- org.apache.hive:hive (Maven): affected from 2.0.0; fixed in 2.0.1
- org.apache.hive:hive-exec (Maven): affected all versions; fixed in 1.2.2
- org.apache.hive:hive-exec (Maven): affected all versions; fixed in 1.2.2
- org.apache.hive:hive-exec (Maven): affected from 2.0.0; fixed in 2.0.1
- org.apache.hive:hive-exec (Maven): affected from 2.0.0; fixed in 2.0.1
- org.apache.hive:hive-service (Maven): affected all versions; fixed in 1.2.2
- org.apache.hive:hive-service (Maven): affected all versions; fixed in 1.2.2
- org.apache.hive:hive-service (Maven): affected from 2.0.0; fixed in 2.0.1
- org.apache.hive:hive-service (Maven): affected from 2.0.0; fixed in 2.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-3083/ (Markdown: https://insights.sbomify.com/CVE-2016-3083/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-3083
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-3083
- OSV: https://osv.dev/vulnerability/CVE-2016-3083

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-3083/
Summaries are generated and may contain mistakes; the official description above is the record.
