{"answers":{"affected":"2 open source packages ship an affected version, including org.cloudfoundry.identity:cloudfoundry-identity-server. It affects 5 products.","exploited":"There is no known exploitation of CVE-2016-3084 in the wild and no public exploit code.","fix":"Upgrade org.cloudfoundry.identity:cloudfoundry-identity-server to 3.3.0.1 or later.","what":"CVE-2016-3084 is a high-severity vulnerability in Pivotal Cloud Foundry, published on 25 May 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-3084 and fix it if it is affected.\n\nWhat it is: CVE-2016-3084 is a high-severity vulnerability in Pivotal Cloud Foundry, published on 25 May 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2016-3084 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected all versions; fixed in 3.3.0.1\n- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected all versions; fixed in 3.3.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-3084/ (Markdown: https://insights.sbomify.com/CVE-2016-3084/index.md)","id":"CVE-2016-3084","markdown":"https://insights.sbomify.com/CVE-2016-3084/index.md","name":"CVE-2016-3084","record":{"aliases":["GHSA-fm5c-2rwc-887w"],"analysis":{"component_type":"cloud_service","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":true,"product_category":"Cloud Foundry UAA","requires_auth":"none","summary":"Attackers can brute force password reset codes in Cloud Foundry UAA when using the internal user store, potentially taking over accounts.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"dell","cpe":[{"product":"cloud_foundry_uaa_bosh","vendor":"cloudfoundry"},{"product":"cloud_foundry","vendor":"pivotal_software"},{"product":"cloud_foundry_elastic_runtime","vendor":"pivotal_software"},{"product":"cloud_foundry_uaa","vendor":"pivotal_software"},{"product":"login-server","vendor":"pivotal_software"}],"cvss":{"score":8.1,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-264","name":null}],"description":"The UAA reset password flow in Cloud Foundry release v236 and earlier versions, UAA release v3.3.0 and earlier versions, all versions of Login-server, UAA release v10 and earlier versions and Pivotal Elastic Runtime versions prior to 1.7.2 is vulnerable to a brute force attack due to multiple active codes at a given time. This vulnerability is applicable only when using the UAA internal user store for authentication. Deployments enabled for integration via SAML or LDAP are not affected.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cloud Foundry UAA reset password vulnerable to brute force attack","id":"CVE-2016-3084","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"security_feature_bypass","year":"2016"},"n_packages":2,"n_references":1,"next":{"headline":"Auth bypass in n/a","id":"CVE-2016-3085"},"packages":[{"ecosystem":"Maven","fixed":["3.3.0.1"],"introduced":["0"],"last_affected":[],"package":"org.cloudfoundry.identity:cloudfoundry-identity-server","purl":null,"source":"GHSA-fm5c-2rwc-887w"},{"ecosystem":"Maven","fixed":["3.3.0.1"],"introduced":["0"],"last_affected":[],"package":"org.cloudfoundry.identity:cloudfoundry-identity-server","purl":"pkg:maven/org.cloudfoundry.identity/cloudfoundry-identity-server","source":"GHSA-fm5c-2rwc-887w"}],"prev":{"headline":"org.apache.hive:hive, org.apache.hive:hive-exec, and org.apache.hive:hive-service vulnerable to Improper Certificate Validation","id":"CVE-2016-3083"},"products":["Cloud Foundry"],"published":"2017-05-25","related":[{"cvss_score":9.6,"headline":"Cloud Foundry vulnerable to Cross-Site Request Forgery","id":"CVE-2016-6637","kev_date_added":null,"published":"2016-09-30"},{"cvss_score":8.8,"headline":"Cloud Foundry UAA Privilege Escalation","id":"CVE-2017-4973","kev_date_added":null,"published":"2017-06-13"},{"cvss_score":8.8,"headline":"SQL injection in n/a","id":"CVE-2016-4468","kev_date_added":null,"published":"2017-04-11"},{"cvss_score":8.8,"headline":"Privilege escalation in n/a","id":"CVE-2016-6651","kev_date_added":null,"published":"2016-09-30"},{"cvss_score":8.1,"headline":"Privilege escalation in Cloud Foundry v247 and earlier and UAA v3.9.2 \u0026 earlier and UAA bosh (uaa-release) v23 \u0026 earlier","id":"CVE-2016-6659","kev_date_added":null,"published":"2016-12-23"},{"cvss_score":7.5,"headline":"Other in Cloud Foundry","id":"CVE-2017-4994","kev_date_added":null,"published":"2017-06-13"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["Pivotal"]},"summary":"Attackers can brute force password reset codes in Cloud Foundry UAA when using the internal user store, potentially taking over accounts.","url":"https://insights.sbomify.com/CVE-2016-3084/"}