# CVE-2016-3084: Cloud Foundry UAA reset password vulnerable to brute force attack

> Attackers can brute force password reset codes in Cloud Foundry UAA when using the internal user store, potentially taking over accounts.

- **Severity:** High 8.1 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 May 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-fm5c-2rwc-887w

## What is CVE-2016-3084?

CVE-2016-3084 is a high-severity vulnerability in Pivotal Cloud Foundry, published on 25 May 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The UAA reset password flow in Cloud Foundry release v236 and earlier versions, UAA release v3.3.0 and earlier versions, all versions of Login-server, UAA release v10 and earlier versions and Pivotal Elastic Runtime versions prior to 1.7.2 is vulnerable to a brute force attack due to multiple active codes at a given time. This vulnerability is applicable only when using the UAA internal user store for authentication. Deployments enabled for integration via SAML or LDAP are not affected.

Weakness: CWE-264

## Which versions are affected by CVE-2016-3084?

2 open source packages ship an affected version, including org.cloudfoundry.identity:cloudfoundry-identity-server. It affects 5 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.cloudfoundry.identity:cloudfoundry-identity-server` | Maven | All versions | 3.3.0.1 |
| `org.cloudfoundry.identity:cloudfoundry-identity-server` | Maven | All versions | 3.3.0.1 |

Products: Cloudfoundry Cloud Foundry Uaa Bosh, Pivotal Software Cloud Foundry, Pivotal Software Cloud Foundry Elastic Runtime, Pivotal Software Cloud Foundry Uaa, Pivotal Software Login-Server.

## How do I fix CVE-2016-3084?

Upgrade org.cloudfoundry.identity:cloudfoundry-identity-server to 3.3.0.1 or later.

## Is CVE-2016-3084 being exploited?

There is no known exploitation of CVE-2016-3084 in the wild and no public exploit code.

## Other vulnerabilities in Pivotal Cloud Foundry

- [CVE-2016-6637](https://insights.sbomify.com/CVE-2016-6637/): Cloud Foundry vulnerable to Cross-Site Request Forgery (critical 9.6)
- [CVE-2017-4973](https://insights.sbomify.com/CVE-2017-4973/): Cloud Foundry UAA Privilege Escalation (high 8.8)
- [CVE-2016-4468](https://insights.sbomify.com/CVE-2016-4468/): SQL injection in n/a (high 8.8)
- [CVE-2016-6651](https://insights.sbomify.com/CVE-2016-6651/): Privilege escalation in n/a (high 8.8)
- [CVE-2016-6659](https://insights.sbomify.com/CVE-2016-6659/): Privilege escalation in Cloud Foundry v247 and earlier and UAA v3.9.2 & earlier and UAA bosh (uaa-release) v23 & earlier (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-3084 and fix it if it is affected.

What it is: CVE-2016-3084 is a high-severity vulnerability in Pivotal Cloud Foundry, published on 25 May 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-3084 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected all versions; fixed in 3.3.0.1
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected all versions; fixed in 3.3.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-3084/ (Markdown: https://insights.sbomify.com/CVE-2016-3084/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-3084
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-3084
- OSV: https://osv.dev/vulnerability/CVE-2016-3084

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-3084/
Summaries are generated and may contain mistakes; the official description above is the record.
