CVE-2016-3086 Exposure of Sensitive Information to an Unauthorized Actor in Apache Hadoop

Critical 9.8 Published Updated

An attacker can leak the credential store password used by the YARN NodeManager, potentially compromising sensitive application credentials.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2016-3086?

CVE-2016-3086 is a critical vulnerability in Apache Hadoop, published on 5 Sep 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

The YARN NodeManager in Apache Hadoop 2.6.x before 2.6.5 and 2.7.x before 2.7.3 can leak the password for credential store provider used by the NodeManager to YARN Applications.

Weakness: CWE-200

Which versions are affected by CVE-2016-3086?

4 open source packages ship an affected version, including org.apache.hadoop:hadoop-yarn-server-nodemanager. It affects 1 product.

PackageAffectedFixed in
org.apache.hadoop:hadoop-yarn-server-nodemanager MavenFrom 2.6.02.6.5
org.apache.hadoop:hadoop-yarn-server-nodemanager MavenFrom 2.6.02.6.5
org.apache.hadoop:hadoop-yarn-server-nodemanager MavenFrom 2.7.02.7.3
org.apache.hadoop:hadoop-yarn-server-nodemanager MavenFrom 2.7.02.7.3

Products include Apache Hadoop.

How do I fix CVE-2016-3086?

Upgrade org.apache.hadoop:hadoop-yarn-server-nodemanager to a fixed version for your release line: 2.6.5 or 2.7.3.

Is CVE-2016-3086 being exploited?

There is no known exploitation of CVE-2016-3086 in the wild and no public exploit code.

Sources

Also known as GHSA-895m-ww55-59vw.

Is CVE-2016-3086 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free